summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/sbc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/sbc')
-rw-r--r--media-libs/sbc/Manifest2
-rw-r--r--media-libs/sbc/metadata.xml9
-rw-r--r--media-libs/sbc/sbc-1.2.ebuild34
-rw-r--r--media-libs/sbc/sbc-1.3.ebuild34
4 files changed, 79 insertions, 0 deletions
diff --git a/media-libs/sbc/Manifest b/media-libs/sbc/Manifest
new file mode 100644
index 000000000000..25f68cdd98ec
--- /dev/null
+++ b/media-libs/sbc/Manifest
@@ -0,0 +1,2 @@
+DIST sbc-1.2.tar.xz 246228 SHA256 c2f01ea54f7473704825113a9cdd46a23e67c650eff575f0670c3d9d66c4a5dc SHA512 65187dbe59e77da312f7dcc9a807959855ef8b6ff0be5403738f9a7b69035806f889d841209755c735525b81c1ba839e858a9ea8316defbc9dfa86104a35ca1d WHIRLPOOL 0496af202879d4f9dcd5cc470ae3cfbaab5e1badae9c9296aeeb082b5fee66657f482efa801d5aa91371e07261f76811d486b0ac2fd8de5e7c3a702505e596d2
+DIST sbc-1.3.tar.xz 246292 SHA256 e61022cf576f14190241e7071753fdacdce5d1dea89ffd704110fc50be689309 SHA512 c11cb1ede8abdb226d404ce34307d217b716b91cbe550ed90cb5387b062b7b97a6b7a81371de6f462d8c1429cb3299869a1bda347fa175e9d81cfa2bc2056c8b WHIRLPOOL 2237003adf9ed226e679034442f73ffe5b2088b51ba229e1435901c351be22c48cc111f86f219e81ad7b162c7e8df41420f329a037a825304d8c21a0c52e8e7f
diff --git a/media-libs/sbc/metadata.xml b/media-libs/sbc/metadata.xml
new file mode 100644
index 000000000000..c9b0be6242ce
--- /dev/null
+++ b/media-libs/sbc/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-libs/sbc/sbc-1.2.ebuild b/media-libs/sbc/sbc-1.2.ebuild
new file mode 100644
index 000000000000..44afba07841f
--- /dev/null
+++ b/media-libs/sbc/sbc-1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib multilib-minimal
+
+DESCRIPTION="An audio codec to connect bluetooth high quality audio devices like headphones or loudspeakers"
+HOMEPAGE="http://git.kernel.org/?p=bluetooth/sbc.git http://www.bluez.org/sbc-10/"
+SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 ppc ppc64 x86"
+IUSE="static-libs"
+
+# --enable-tester is building src/sbctester but the tarball is missing required
+# .wav file to execute it
+RESTRICT="test"
+
+DEPEND="virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --disable-tester
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+}
diff --git a/media-libs/sbc/sbc-1.3.ebuild b/media-libs/sbc/sbc-1.3.ebuild
new file mode 100644
index 000000000000..8e4ad1f50f71
--- /dev/null
+++ b/media-libs/sbc/sbc-1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib multilib-minimal
+
+DESCRIPTION="An audio codec to connect bluetooth high quality audio devices like headphones or loudspeakers"
+HOMEPAGE="http://git.kernel.org/?p=bluetooth/sbc.git http://www.bluez.org/sbc-10/"
+SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="static-libs"
+
+# --enable-tester is building src/sbctester but the tarball is missing required
+# .wav file to execute it
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --disable-tester
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}