summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-31 20:16:48 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-31 20:17:07 +0100
commit4b8e9ca20e6f300b2d0e18d2311690d0415699d0 (patch)
tree2c6969370b5ea054c102ba79e3abe1b36dd644b7 /media-libs/sdif/sdif-3.11.4.ebuild
parentskel.metadata.xml: update for GLEP 67 (diff)
downloadgentoo-4b8e9ca20e6f300b2d0e18d2311690d0415699d0.tar.gz
gentoo-4b8e9ca20e6f300b2d0e18d2311690d0415699d0.tar.bz2
gentoo-4b8e9ca20e6f300b2d0e18d2311690d0415699d0.zip
media-libs/sdif: Version bump to 3.11.4
Gentoo-Bug: 572686 * EAPI=6 * Remove USE="doc" Package-Manager: portage-2.2.27
Diffstat (limited to 'media-libs/sdif/sdif-3.11.4.ebuild')
-rw-r--r--media-libs/sdif/sdif-3.11.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/sdif/sdif-3.11.4.ebuild b/media-libs/sdif/sdif-3.11.4.ebuild
new file mode 100644
index 000000000000..48265bfe1c15
--- /dev/null
+++ b/media-libs/sdif/sdif-3.11.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="Sound Description Interchange Format Library for audio and wave processing"
+HOMEPAGE="http://sourceforge.net/projects/sdif/"
+SRC_URI="http://sourceforge.net/projects/sdif/files/sdif/SDIF-${PV}/SDIF-${PV}-src.zip"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug ftruncate threads"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-buildsystem.patch"
+)
+S="${WORKDIR}/SDIF-${PV}-src"
+
+src_prepare() {
+ mv configure.{in,ac} || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable ftruncate) \
+ $(use_enable threads pthreads)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}