summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-01-25 15:55:27 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-01-25 15:55:27 +0100
commit33a4a05a3aafe556f5b926688e5bceebb68871b9 (patch)
treee3de6f12e76e94e4e1ce425fa7e89c0c754b13cd /media-libs/sdl2-ttf/sdl2-ttf-2.0.15.ebuild
parentsys-libs/db: Bump to version 18.1.25 (diff)
downloadgentoo-33a4a05a3aafe556f5b926688e5bceebb68871b9.tar.gz
gentoo-33a4a05a3aafe556f5b926688e5bceebb68871b9.tar.bz2
gentoo-33a4a05a3aafe556f5b926688e5bceebb68871b9.zip
media-libs/sdl2-ttf: Bump to version 2.0.15
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/sdl2-ttf/sdl2-ttf-2.0.15.ebuild')
-rw-r--r--media-libs/sdl2-ttf/sdl2-ttf-2.0.15.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/sdl2-ttf/sdl2-ttf-2.0.15.ebuild b/media-libs/sdl2-ttf/sdl2-ttf-2.0.15.ebuild
new file mode 100644
index 000000000000..3a6aae37a7df
--- /dev/null
+++ b/media-libs/sdl2-ttf/sdl2-ttf-2.0.15.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-minimal
+
+MY_P="SDL2_ttf-${PV}"
+DESCRIPTION="library that allows you to use TrueType fonts in SDL applications"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_ttf/"
+SRC_URI="http://www.libsdl.org/projects/SDL_ttf/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs X"
+
+RDEPEND="X? ( >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}] )
+ >=media-libs/libsdl2-2.0.1-r1[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]
+ virtual/opengl[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_with X x)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ dodoc {CHANGES,README}.txt
+ find "${ED}" -name '*.la' -delete || die
+}