summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-07 21:35:22 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-07 21:39:40 +0200
commita44989ce5f8f8d92a61bc4c8fa5ffd6cb1d9dcb7 (patch)
tree7a8b523adc69ddf1a95828373f1f8aa026b895c9 /media-libs/sge/sge-030809.ebuild
parentx11-libs/gtk+: stable 2.24.32 for ia64, bug #660314 (diff)
downloadgentoo-a44989ce5f8f8d92a61bc4c8fa5ffd6cb1d9dcb7.tar.gz
gentoo-a44989ce5f8f8d92a61bc4c8fa5ffd6cb1d9dcb7.tar.bz2
gentoo-a44989ce5f8f8d92a61bc4c8fa5ffd6cb1d9dcb7.zip
media-libs/sge: Use pkg-config instead of freetype-config.
Closes: https://bugs.gentoo.org/655798 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'media-libs/sge/sge-030809.ebuild')
-rw-r--r--media-libs/sge/sge-030809.ebuild32
1 files changed, 21 insertions, 11 deletions
diff --git a/media-libs/sge/sge-030809.ebuild b/media-libs/sge/sge-030809.ebuild
index 6bff1d0d2baf..159379bb02fd 100644
--- a/media-libs/sge/sge-030809.ebuild
+++ b/media-libs/sge/sge-030809.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils multilib toolchain-funcs
+EAPI=6
+inherit multilib toolchain-funcs
MY_P="sge${PV}"
DESCRIPTION="Graphics extensions library for SDL"
@@ -14,17 +14,24 @@ SLOT="0"
KEYWORDS="amd64 ~ia64 ppc x86 ~x86-fbsd"
IUSE="doc examples image truetype"
-DEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl
image? ( media-libs/sdl-image )
truetype? ( >=media-libs/freetype-2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-freetype.patch
+ "${FILESDIR}"/${P}-cmap.patch
+ "${FILESDIR}"/${P}-freetype_pkgconfig.patch
+)
+
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-freetype.patch \
- "${FILESDIR}"/${P}-cmap.patch
+ default
sed -i "s:\$(PREFIX)/lib:\$(PREFIX)/$(get_libdir):" Makefile || die
sed -i \
-e '/^CC=/d' \
@@ -43,10 +50,13 @@ src_compile() {
}
src_install() {
- DOCS="README Todo WhatsNew" \
- default
+ local DOCS=( README Todo WhatsNew )
+ default
- use doc && dohtml docs/*
+ if use doc ; then
+ docinto html
+ dodoc docs/*
+ fi
if use examples ; then
insinto /usr/share/doc/${PF}