summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 09:01:59 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:51 +0100
commitd5897bfafe18dff296a94f0b0f66c8a6e9408a46 (patch)
tree68361602728eab91054976fcf33f558890f67e44 /media-libs/sge
parentgames-arcade/aop: respect PKG_CONFIG (diff)
downloadgentoo-d5897bfafe18dff296a94f0b0f66c8a6e9408a46.tar.gz
gentoo-d5897bfafe18dff296a94f0b0f66c8a6e9408a46.tar.bz2
gentoo-d5897bfafe18dff296a94f0b0f66c8a6e9408a46.zip
media-libs/sge: respect PKG_CONFIG, multilib--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/sge')
-rw-r--r--media-libs/sge/files/sge-030809-freetype_pkgconfig.patch10
-rw-r--r--media-libs/sge/sge-030809.ebuild7
2 files changed, 9 insertions, 8 deletions
diff --git a/media-libs/sge/files/sge-030809-freetype_pkgconfig.patch b/media-libs/sge/files/sge-030809-freetype_pkgconfig.patch
index ceb478f3d828..738f4e2aeaa8 100644
--- a/media-libs/sge/files/sge-030809-freetype_pkgconfig.patch
+++ b/media-libs/sge/files/sge-030809-freetype_pkgconfig.patch
@@ -1,7 +1,7 @@
https://bugs.gentoo.org/655798
---- sge030809/Makefile.conf
-+++ sge030809/Makefile.conf
+--- a/Makefile.conf
++++ b/Makefile.conf
@@ -35,16 +35,16 @@
SGE_LIBS =$(shell sdl-config --libs) -lstdc++
@@ -9,7 +9,7 @@ https://bugs.gentoo.org/655798
-# Is freetype-config available?
-HAVE_FT =$(shell if (freetype-config --version) < /dev/null > /dev/null 2>&1; then echo "y"; else echo "n"; fi;)
+# Is freetype available?
-+HAVE_FT =$(shell if pkg-config --exists freetype2 ; then echo "y"; else echo "n"; fi;)
++HAVE_FT =$(shell if ${PKG_CONFIG} --exists freetype2 ; then echo "y"; else echo "n"; fi;)
ifeq ($(HAVE_FT),n)
USE_FT = n
endif
@@ -18,8 +18,8 @@ https://bugs.gentoo.org/655798
USE_FT = y
- SGE_LIBS +=$(shell freetype-config --libs)
- FT_CFLAGS =$(shell freetype-config --cflags)
-+ SGE_LIBS +=$(shell pkg-config --libs freetype2)
-+ FT_CFLAGS =$(shell pkg-config --cflags freetype2)
++ SGE_LIBS +=$(shell ${PKG_CONFIG} --libs freetype2)
++ FT_CFLAGS =$(shell ${PKG_CONFIG} --cflags freetype2)
endif
diff --git a/media-libs/sge/sge-030809.ebuild b/media-libs/sge/sge-030809.ebuild
index b3eb1819a16f..a84e9aa3238f 100644
--- a/media-libs/sge/sge-030809.ebuild
+++ b/media-libs/sge/sge-030809.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit multilib toolchain-funcs
+
+inherit toolchain-funcs
MY_P="sge${PV}"
DESCRIPTION="Graphics extensions library for SDL"
@@ -38,7 +39,7 @@ src_prepare() {
-e '/^CXX=/d' \
-e '/^AR=/d' \
Makefile.conf || die
- tc-export CC CXX AR
+ tc-export CC CXX AR PKG_CONFIG
# make sure the header gets regenerated everytime
rm -f sge_config.h
}