summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-06-25 11:16:35 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-06-25 11:17:12 +0200
commit63d167dda2f2bd848655e37679f5cac460fc9f47 (patch)
treed998a66fef8c5e490faa256b07201de23eb22d7d /media-libs/speexdsp/speexdsp-1.2.1.ebuild
parentdev-python/h5py: Stabilize 3.7.0 x86, #853988 (diff)
downloadgentoo-63d167dda2f2bd848655e37679f5cac460fc9f47.tar.gz
gentoo-63d167dda2f2bd848655e37679f5cac460fc9f47.tar.bz2
gentoo-63d167dda2f2bd848655e37679f5cac460fc9f47.zip
media-libs/speexdsp: bump to 1.2.1, eapi8 + cleanup
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/speexdsp/speexdsp-1.2.1.ebuild')
-rw-r--r--media-libs/speexdsp/speexdsp-1.2.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/speexdsp/speexdsp-1.2.1.ebuild b/media-libs/speexdsp/speexdsp-1.2.1.ebuild
new file mode 100644
index 000000000000..032d3178895f
--- /dev/null
+++ b/media-libs/speexdsp/speexdsp-1.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic multilib-minimal
+
+MY_P=${P/_}
+MY_P=${MY_P/_p/.}
+
+DESCRIPTION="Audio compression format designed for speech -- DSP"
+HOMEPAGE="https://www.speex.org/"
+SRC_URI="https://downloads.xiph.org/releases/speex/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_arm_neon"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.0-configure.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:noinst_PROGRAMS:check_PROGRAMS:' \
+ libspeexdsp/Makefile.am || die
+
+ eautoreconf
+
+ append-lfs-flags
+}
+
+multilib_src_configure() {
+ # Can also be configured with one of:
+ # --enable-fixed-point (no floating point)
+ # --with-fft=proprietary-intel-mkl (mkl)
+ # --with-fft=gpl-fftw3 (fftw)
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable cpu_flags_arm_neon neon)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -type f -delete || die
+}