summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-09-18 15:17:08 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-09-18 15:34:28 +0200
commit690b0c79e8f921246347194e62a9a6de6b35ea85 (patch)
tree46abd5a7670f30c7fd33ce744572e900221f05d1 /media-libs/suil
parentmedia-video/makemkv: Drop obsolete wget dependency (diff)
downloadgentoo-690b0c79e8f921246347194e62a9a6de6b35ea85.tar.gz
gentoo-690b0c79e8f921246347194e62a9a6de6b35ea85.tar.bz2
gentoo-690b0c79e8f921246347194e62a9a6de6b35ea85.zip
media-libs/suil: improvements to 0.10.16
- Fix copypasta longdescription in metadata.xml - Fix HOMEPAGE and SRC_URI - Remove python dependency: there is no python involved in suil. For building the docs, the dependency should be fine (?) - add gtk2 useflag and dependencies - add X useflag and dependencies - Add missing Qt5 dependencies - simplify dependencies managemen Patch by Olivier Huber <oli.huber@gmail.com> Closes: https://bugs.gentoo.org/863614 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/suil')
-rw-r--r--media-libs/suil/metadata.xml18
-rw-r--r--media-libs/suil/suil-0.10.16-r1.ebuild (renamed from media-libs/suil/suil-0.10.16.ebuild)37
2 files changed, 34 insertions, 21 deletions
diff --git a/media-libs/suil/metadata.xml b/media-libs/suil/metadata.xml
index f9a9fe3099dc..ef7c2a13b89e 100644
--- a/media-libs/suil/metadata.xml
+++ b/media-libs/suil/metadata.xml
@@ -1,11 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>proaudio@gentoo.org</email>
- <name>Gentoo ProAudio Project</name>
-</maintainer>
-<longdescription lang="en">
- Lilv is a library to make the use of LV2 plugins as simple as possible for applications. Lilv is the successor to SLV2, rewritten to be significantly faster and have minimal dependencies.
-</longdescription>
+ <maintainer type="project">
+ <email>proaudio@gentoo.org</email>
+ <name>Gentoo ProAudio Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Suil makes it possible to load a UI of any toolkit in a host using any other toolkit.
+ Suil currently supports every combination of Gtk 2, Gtk 3, Qt 5, and X11.
+ </longdescription>
+ <use>
+ <flag name="gtk2">Enable GTK2 based GUI support</flag>
+ </use>
</pkgmetadata>
diff --git a/media-libs/suil/suil-0.10.16.ebuild b/media-libs/suil/suil-0.10.16-r1.ebuild
index 951d4de5215c..710d7c1ed85d 100644
--- a/media-libs/suil/suil-0.10.16.ebuild
+++ b/media-libs/suil/suil-0.10.16-r1.ebuild
@@ -3,19 +3,16 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_REQ_USE='threads(+)'
-
-inherit meson python-any-r1
+inherit meson
DESCRIPTION="Lightweight C library for loading and wrapping LV2 plugin UIs"
-HOMEPAGE="http://drobilla.net/software/suil/"
-SRC_URI="http://download.drobilla.net/${P}.tar.xz"
+HOMEPAGE="https://drobilla.net/software/suil.html"
+SRC_URI="https://download.drobilla.net/${P}.tar.xz"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE="doc gtk qt5"
+IUSE="doc gtk gtk2 qt5 X"
BDEPEND="
virtual/pkgconfig
@@ -25,19 +22,29 @@ BDEPEND="
dev-python/sphinx_lv2_theme
)
"
-CDEPEND="
+# This could be way refined, but it's quickly a rabbit hole
+
+RDEPEND="
media-libs/lv2
- gtk? ( x11-libs/gtk+:2 )
+ gtk2? (
+ x11-libs/gtk+:2
+ dev-libs/glib:2
+ )
+ gtk? (
+ x11-libs/gtk+:3
+ dev-libs/glib:2
+ )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
- )"
-RDEPEND="${CDEPEND}"
-DEPEND="
- ${CDEPEND}
- ${PYTHON_DEPS}
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ )
+ X? ( x11-libs/libX11 )
"
+DEPEND="${RDEPEND}"
+
DOCS=( AUTHORS NEWS README.md )
src_prepare() {
@@ -50,8 +57,10 @@ src_prepare() {
src_configure() {
local emesonargs=(
$(meson_feature doc docs)
+ $(meson_feature gtk2)
$(meson_feature gtk gtk3)
$(meson_feature qt5)
+ $(meson_feature X x11)
)
meson_src_configure