summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-05-06 17:38:26 -0700
committerMatt Turner <mattst88@gentoo.org>2018-05-06 17:39:40 -0700
commit6e1fd7415057efe313e0a0f73f3a105730748e28 (patch)
treee0fa07b25690cd57b11c43ac3327eec715d29936 /media-libs/t1lib/t1lib-5.1.2-r2.ebuild
parentkde-misc/yakuake: x86 stable (bug #655066) (diff)
downloadgentoo-6e1fd7415057efe313e0a0f73f3a105730748e28.tar.gz
gentoo-6e1fd7415057efe313e0a0f73f3a105730748e28.tar.bz2
gentoo-6e1fd7415057efe313e0a0f73f3a105730748e28.zip
media-libs/t1lib: Drop unnecessary dependency on x11-libs/libXfont
Transition to depending on x11-base/xorg-proto while we're here. Closes: https://bugs.gentoo.org/655106
Diffstat (limited to 'media-libs/t1lib/t1lib-5.1.2-r2.ebuild')
-rw-r--r--media-libs/t1lib/t1lib-5.1.2-r2.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/media-libs/t1lib/t1lib-5.1.2-r2.ebuild b/media-libs/t1lib/t1lib-5.1.2-r2.ebuild
new file mode 100644
index 000000000000..e763c5eb15a6
--- /dev/null
+++ b/media-libs/t1lib/t1lib-5.1.2-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic libtool toolchain-funcs
+
+DESCRIPTION="A Type 1 Font Rasterizer Library for UNIX/X11"
+HOMEPAGE="ftp://metalab.unc.edu/pub/Linux/libs/graphics/"
+SRC_URI="ftp://sunsite.unc.edu/pub/Linux/libs/graphics/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="5"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="X doc static-libs"
+
+RDEPEND="X? (
+ x11-libs/libXaw
+ x11-libs/libX11
+ x11-libs/libXt
+ )"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )
+ X? ( x11-base/xorg-proto )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.1.1-parallel.patch
+ "${FILESDIR}"/${PN}-do-not-install-t1lib_doc-r1.patch
+ "${FILESDIR}"/${PN}-5.1.2-format-security.patch
+ "${FILESDIR}"/${PN}-5.1.2-CVE-2010-2642_2011-0433_2011-5244.patch
+ "${FILESDIR}"/${PN}-5.1.2-CVE-2011-0764.patch
+ "${FILESDIR}"/${PN}-5.1.2-CVE-2011-1552_1553_1554.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e "s:dvips:#dvips:" "${S}"/doc/Makefile.in
+ sed -i -e "s:\./\(t1lib\.config\):/etc/t1lib/\1:" "${S}"/xglyph/xglyph.c
+ # Needed for sane .so versionning on fbsd. Please don't drop.
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --datadir="${EPREFIX}/etc" \
+ $(use_enable static-libs static) \
+ $(use_with X x)
+}
+
+src_compile() {
+ local myopt=""
+ tc-export CC
+
+ use alpha && append-flags -mieee
+
+ if ! use doc; then
+ myopt="without_doc"
+ else
+ VARTEXFONTS=${T}/fonts
+ fi
+
+ emake ${myopt}
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${ED}"usr/lib* -name '*.la' -o -name '*.a' -delete || die
+ fi
+
+ dodoc Changes README*
+ if use doc; then
+ cd doc
+ insinto /usr/share/doc/${PF}
+ doins *.pdf *.dvi
+ fi
+}