summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.5.ebuild')
-rw-r--r--media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.5.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.5.ebuild b/media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.5.ebuild
new file mode 100644
index 000000000000..8a4b6787deeb
--- /dev/null
+++ b/media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils multilib
+
+DESCRIPTION="Audio processing plugin system for plugins that extract descriptive information from audio data"
+HOMEPAGE="http://www.vamp-plugins.org"
+SRC_URI="http://code.soundsoftware.ac.uk/attachments/download/690/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ~mips ppc ppc64 x86"
+IUSE="doc"
+
+RDEPEND="media-libs/libsndfile"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # multilib for default search paths
+ sed -i -e "s:/usr/lib/vamp:/usr/$(get_libdir)/vamp:" src/vamp-hostsdk/PluginHostAdapter.cpp || die "sed failed"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
+ if use doc; then
+ cd build
+ doxygen || die "creating doxygen doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_SDK_LIBS="/usr/$(get_libdir)" INSTALL_PKGCONFIG="/usr/$(get_libdir)/pkgconfig" INSTALL_PLUGINS="/usr/$(get_libdir)/vamp" install
+ dodoc README* CHANGELOG
+ use doc && dohtml -r build/doc/html/*
+}
+
+pkg_postinst() {
+ elog ""
+ elog "You might also want to install some Vamp plugins."
+ elog "See media-plugins/vamp-*"
+ elog ""
+}