summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2018-05-26 18:43:30 -0400
committerNick Sarnie <sarnex@gentoo.org>2018-05-26 18:58:31 -0400
commit38d17659cf946552a99a071c7cb2fdffc0c5c681 (patch)
treead1236da4c7f1f99c4c1c2e07a0b5c9ead4d118e /media-libs/vulkan-loader/vulkan-loader-9999.ebuild
parentmedia-libs/vulkan-tools: Initial version (diff)
downloadgentoo-38d17659cf946552a99a071c7cb2fdffc0c5c681.tar.gz
gentoo-38d17659cf946552a99a071c7cb2fdffc0c5c681.tar.bz2
gentoo-38d17659cf946552a99a071c7cb2fdffc0c5c681.zip
media-libs/vulkan-loader: Adapt 9999 to new packaging
Change EGIT_REPO_URI Drop demos USE Depend on media-libs/vulkan-layers for layers USE Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-libs/vulkan-loader/vulkan-loader-9999.ebuild')
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-9999.ebuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/media-libs/vulkan-loader/vulkan-loader-9999.ebuild b/media-libs/vulkan-loader/vulkan-loader-9999.ebuild
index b83dbcb76bcd..ddfe098eb54c 100644
--- a/media-libs/vulkan-loader/vulkan-loader-9999.ebuild
+++ b/media-libs/vulkan-loader/vulkan-loader-9999.ebuild
@@ -5,12 +5,13 @@ EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )
if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git"
+ EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Loader.git"
+ EGIT_SUBMODULES=()
inherit git-r3
else
KEYWORDS="~amd64"
- SRC_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/Vulkan-LoaderAndValidationLayers-sdk-${PV}"
+ SRC_URI="https://github.com/KhronosGroup/Vulkan-Loader/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Vulkan-Loader-sdk-${PV}"
fi
inherit python-any-r1 cmake-multilib
@@ -20,31 +21,27 @@ HOMEPAGE="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="demos layers wayland X"
-REQUIRED_USE="demos? ( X )"
+IUSE="layers wayland X"
RDEPEND=""
DEPEND="${PYTHON_DEPS}
- demos? ( dev-util/glslang:=[${MULTILIB_USEDEP}] )
- layers? (
- dev-util/glslang:=[${MULTILIB_USEDEP}]
- >=dev-util/spirv-tools-2018.2-r1:=[${MULTILIB_USEDEP}]
- )
+ dev-util/vulkan-headers
+ layers? ( media-libs/vulkan-layers:=[${MULTILIB_USEDEP}] )
wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
X? (
x11-libs/libX11:=[${MULTILIB_USEDEP}]
x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
)"
-PATCHES=( "${FILESDIR}/${PN}-Use-a-file-to-get-the-spirv-tools-commit-ID.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-Do-not-install-vulkan-headers.patch"
+ "${FILESDIR}/${P}-Use-usr-for-vulkan-headers.patch"
+)
multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=True
-DBUILD_TESTS=False
- -DBUILD_LAYERS=$(usex layers)
- -DBUILD_DEMOS=$(usex demos)
- -DBUILD_VKJSON=False
-DBUILD_LOADER=True
-DBUILD_WSI_MIR_SUPPORT=False
-DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
@@ -59,3 +56,8 @@ multilib_src_install() {
cmake-utils_src_install
}
+
+pkg_postinst() {
+ einfo "USE=demos has been dropped as per upstream packaging"
+ einfo "vulkaninfo is now available in the media-libs/vulkan-tools package"
+}