summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <commendsarnex@gmail.com>2018-03-23 21:57:37 -0400
committerMatt Turner <mattst88@gentoo.org>2018-04-14 12:50:21 -0700
commit7b7094dde1494d5a38fdc6b8bdb207e8a2d8a0d3 (patch)
tree6f41d3731556fa7b561bb15acdb7c4ab2d536c27 /media-libs/vulkan-loader/vulkan-loader-9999.ebuild
parentdev-util/spirv-tools: Revbump and add a header that includes git SHA1 for vul... (diff)
downloadgentoo-7b7094dde1494d5a38fdc6b8bdb207e8a2d8a0d3.tar.gz
gentoo-7b7094dde1494d5a38fdc6b8bdb207e8a2d8a0d3.tar.bz2
gentoo-7b7094dde1494d5a38fdc6b8bdb207e8a2d8a0d3.zip
media-libs/vulkan-loader: Add layers USE
Closes: https://bugs.gentoo.org/619124
Diffstat (limited to 'media-libs/vulkan-loader/vulkan-loader-9999.ebuild')
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/media-libs/vulkan-loader/vulkan-loader-9999.ebuild b/media-libs/vulkan-loader/vulkan-loader-9999.ebuild
index 67822d5a388d..b3a7e0743f44 100644
--- a/media-libs/vulkan-loader/vulkan-loader-9999.ebuild
+++ b/media-libs/vulkan-loader/vulkan-loader-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,22 +20,28 @@ HOMEPAGE="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="demos wayland X"
+IUSE="demos layers wayland X"
RDEPEND=""
DEPEND="${PYTHON_DEPS}
demos? ( dev-util/glslang:=[${MULTILIB_USEDEP}] )
+ layers? (
+ dev-util/glslang:=[${MULTILIB_USEDEP}]
+ >=dev-util/spirv-tools-2018.2-r1:=[${MULTILIB_USEDEP}]
+ )
wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
X? (
x11-libs/libX11:=[${MULTILIB_USEDEP}]
x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
)"
+PATCHES=( "${FILESDIR}/${PN}-Use-a-file-to-get-the-spirv-tools-commit-ID.patch" )
+
multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=True
-DBUILD_TESTS=False
- -DBUILD_LAYERS=False
+ -DBUILD_LAYERS=$(usex layers)
-DBUILD_DEMOS=$(usex demos)
-DBUILD_VKJSON=False
-DBUILD_LOADER=True