summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2023-06-11 21:14:06 -0400
committerNick Sarnie <sarnex@gentoo.org>2023-06-11 21:21:37 -0400
commit1f6632889b6f9389cab9cec029ec5323e31cc786 (patch)
tree97cbe6060973feee497398eded8f9374a86afaae /media-libs/vulkan-loader
parentmedia-libs/vulkan-layers: enable py3.12 (diff)
downloadgentoo-1f6632889b6f9389cab9cec029ec5323e31cc786.tar.gz
gentoo-1f6632889b6f9389cab9cec029ec5323e31cc786.tar.bz2
gentoo-1f6632889b6f9389cab9cec029ec5323e31cc786.zip
media-libs/vulkan-loader: add 1.3.250
Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'media-libs/vulkan-loader')
-rw-r--r--media-libs/vulkan-loader/Manifest1
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.3.250.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/vulkan-loader/Manifest b/media-libs/vulkan-loader/Manifest
index 19add717508f..76a451e7b9d2 100644
--- a/media-libs/vulkan-loader/Manifest
+++ b/media-libs/vulkan-loader/Manifest
@@ -1,2 +1,3 @@
DIST vulkan-loader-1.3.243.tar.gz 1656575 BLAKE2B 1f54ab205610b7e1b9db7ce4039a22dccf4971d48b64b70e156ef9d9d59cce7fee6968459d85b1eb949461fa07ad0daa432c064fcf6647d61229a634a054a196 SHA512 8c551a9c1d04d671cc63327709bf000bce44f8bf323b8eb10ca6c5e960aa44cbb4c25681a1ecfaf1359eeb07ab9de5229ccdd395c8053c8a48e13724fb72dce7
DIST vulkan-loader-1.3.246.tar.gz 1657751 BLAKE2B 1e4f6000a3f0708edbf4bbfb02098462ce6fc05222f1c48eccfedf0ec9db37e1ae41a2833c2ff6d78cfe0395fee65e89643075989fa7a47a01d0c4fe65dec307 SHA512 3f24de3147c885cd555fc3aa4d728e013f13dd1eb832a1b3a8fb5fcc8eb561af7080734c00ed3d2ff8f86138a626f6dfb0138f7c72386f02fbcb5b5fbf4c98e4
+DIST vulkan-loader-1.3.250.tar.gz 1660983 BLAKE2B 4befda9543f1046cc31bc41848d54f2812c9aac171510523683e003f58c41dd67966a898e0f4ca60d9e61f716f9bc8b968af0b265f80088026903b938323aaa9 SHA512 89561e0343098fdc62c0d469639d6f41ac9ee57ef54f9a91eee0f0645fa12ed15e397575eab9d829b02ec2a4d1bfd2b9239ae27b0ebdc0286f07177880cdf2b5
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.3.250.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.3.250.ebuild
new file mode 100644
index 000000000000..a79a918b7b9b
--- /dev/null
+++ b/media-libs/vulkan-loader/vulkan-loader-1.3.250.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=Vulkan-Loader
+inherit flag-o-matic cmake-multilib toolchain-funcs
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
+ EGIT_SUBMODULES=()
+ inherit git-r3
+else
+ SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}"/${MY_PN}-sdk-${PV}
+fi
+
+DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Loader"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="layers wayland X"
+
+DEPEND="
+ ~dev-util/vulkan-headers-${PV}
+ wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11:=[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
+ )
+"
+PDEPEND="layers? ( media-libs/vulkan-layers:=[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ # Integrated clang assembler doesn't work with x86 - Bug #698164
+ if tc-is-clang && [[ ${ABI} == x86 ]]; then
+ append-cflags -fno-integrated-as
+ fi
+
+ local mycmakeargs=(
+ -DCMAKE_C_FLAGS="${CFLAGS} -DNDEBUG"
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS} -DNDEBUG"
+ -DCMAKE_SKIP_RPATH=ON
+ -DBUILD_TESTS=OFF
+ -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
+ -DBUILD_WSI_XCB_SUPPORT=$(usex X)
+ -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
+ -DVULKAN_HEADERS_INSTALL_DIR="${ESYSROOT}/usr"
+ -DENABLE_WERROR=OFF
+ )
+ cmake_src_configure
+}
+
+multilib_src_install() {
+ keepdir /etc/vulkan/icd.d
+
+ cmake_src_install
+}