summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-24 19:22:00 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-26 13:19:34 -0700
commitb888c2beb109bb0a1e6d8868dc42d805fea8c33f (patch)
tree9906e6257dd72d638f8a1e5481eb7b0afdd39bae /media-libs/vulkan-loader
parentmedia-libs/vulkan-layers: Move dev-util/spirv-tools to RDEPEND (diff)
downloadgentoo-b888c2beb109bb0a1e6d8868dc42d805fea8c33f.tar.gz
gentoo-b888c2beb109bb0a1e6d8868dc42d805fea8c33f.tar.bz2
gentoo-b888c2beb109bb0a1e6d8868dc42d805fea8c33f.zip
media-libs/vulkan-loader: Remove unnecessary Python dependency
There's an optional "VulkanLoader_generated_source" target that requires Python 3, but it's not used during the build. Instead the generated files are checked into git and thus are available in the tarball. Noticed because of a patch in the chromiumos-overlay that moved ${PYTHON_DEPS} to BDEPEND (which would make sense if Python was actually used during the build). Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/vulkan-loader')
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.2.179.ebuild5
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-9999.ebuild7
2 files changed, 5 insertions, 7 deletions
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.2.179.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.2.179.ebuild
index bf6ea8c4f69d..5eecd8d168e1 100644
--- a/media-libs/vulkan-loader/vulkan-loader-1.2.179.ebuild
+++ b/media-libs/vulkan-loader/vulkan-loader-1.2.179.ebuild
@@ -5,8 +5,7 @@ EAPI=7
MY_PN=Vulkan-Loader
CMAKE_ECLASS="cmake"
-PYTHON_COMPAT=( python3_{8,9} )
-inherit flag-o-matic cmake-multilib python-any-r1 toolchain-funcs
+inherit flag-o-matic cmake-multilib toolchain-funcs
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
@@ -26,7 +25,7 @@ SLOT="0"
IUSE="layers wayland X"
BDEPEND=">=dev-util/cmake-3.10.2"
-DEPEND="${PYTHON_DEPS}
+DEPEND="
~dev-util/vulkan-headers-${PV}
wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
X? (
diff --git a/media-libs/vulkan-loader/vulkan-loader-9999.ebuild b/media-libs/vulkan-loader/vulkan-loader-9999.ebuild
index c4eb156e64f8..22fae7e60678 100644
--- a/media-libs/vulkan-loader/vulkan-loader-9999.ebuild
+++ b/media-libs/vulkan-loader/vulkan-loader-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_PN=Vulkan-Loader
CMAKE_ECLASS="cmake"
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit flag-o-matic cmake-multilib python-any-r1 toolchain-funcs
+inherit flag-o-matic cmake-multilib toolchain-funcs
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
@@ -26,7 +25,7 @@ SLOT="0"
IUSE="layers wayland X"
BDEPEND=">=dev-util/cmake-3.10.2"
-DEPEND="${PYTHON_DEPS}
+DEPEND="
>=dev-util/vulkan-headers-${PV}
wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
X? (