summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-10-24 13:48:54 -0400
committerMatt Turner <mattst88@gentoo.org>2023-10-24 13:58:57 -0400
commitd7bd92464f7fadf91b419ea2adf8ab7326653dd8 (patch)
treee05f33c5a0ed79c1b850b5f88ed659b0556febb7 /media-libs/vulkan-loader
parentmedia-libs/vulkan-layers: Drop old versions (diff)
downloadgentoo-d7bd92464f7fadf91b419ea2adf8ab7326653dd8.tar.gz
gentoo-d7bd92464f7fadf91b419ea2adf8ab7326653dd8.tar.bz2
gentoo-d7bd92464f7fadf91b419ea2adf8ab7326653dd8.zip
media-libs/vulkan-loader: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/vulkan-loader')
-rw-r--r--media-libs/vulkan-loader/Manifest1
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.3.250.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/media-libs/vulkan-loader/Manifest b/media-libs/vulkan-loader/Manifest
index 9c3701669cfd..4f60af3d3189 100644
--- a/media-libs/vulkan-loader/Manifest
+++ b/media-libs/vulkan-loader/Manifest
@@ -1,2 +1 @@
-DIST vulkan-loader-1.3.250.tar.gz 1660983 BLAKE2B 4befda9543f1046cc31bc41848d54f2812c9aac171510523683e003f58c41dd67966a898e0f4ca60d9e61f716f9bc8b968af0b265f80088026903b938323aaa9 SHA512 89561e0343098fdc62c0d469639d6f41ac9ee57ef54f9a91eee0f0645fa12ed15e397575eab9d829b02ec2a4d1bfd2b9239ae27b0ebdc0286f07177880cdf2b5
DIST vulkan-loader-1.3.261.tar.gz 1684713 BLAKE2B 0321a56329cc8f578e07c24a53846f0a3ac9f81ce897975f0d0732db6a6ab905e682a81cb232d96d01311a9d9b89fb142b3c0eca5330371f42ba52e12c7ed2cc SHA512 f43bf9714c30b0751d9f6725ad7df7f70516b5e12a637bfb4cdf175b33d2be78e1717a3ae9537544ca84e0c89d5b759d537b932eec7f5502fcc871f6cdaa440c
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.3.250.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.3.250.ebuild
deleted file mode 100644
index 9134cc68f453..000000000000
--- a/media-libs/vulkan-loader/vulkan-loader-1.3.250.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_PN=Vulkan-Loader
-inherit flag-o-matic cmake-multilib toolchain-funcs
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
- EGIT_SUBMODULES=()
- inherit git-r3
-else
- SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv x86"
- S="${WORKDIR}"/${MY_PN}-sdk-${PV}
-fi
-
-DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
-HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Loader"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="layers wayland X"
-
-DEPEND="
- ~dev-util/vulkan-headers-${PV}
- wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
- X? (
- x11-libs/libX11:=[${MULTILIB_USEDEP}]
- x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
- )
-"
-PDEPEND="layers? ( media-libs/vulkan-layers:=[${MULTILIB_USEDEP}] )"
-
-multilib_src_configure() {
- # Integrated clang assembler doesn't work with x86 - Bug #698164
- if tc-is-clang && [[ ${ABI} == x86 ]]; then
- append-cflags -fno-integrated-as
- fi
-
- local mycmakeargs=(
- -DCMAKE_C_FLAGS="${CFLAGS} -DNDEBUG"
- -DCMAKE_CXX_FLAGS="${CXXFLAGS} -DNDEBUG"
- -DCMAKE_SKIP_RPATH=ON
- -DBUILD_TESTS=OFF
- -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
- -DBUILD_WSI_XCB_SUPPORT=$(usex X)
- -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
- -DVULKAN_HEADERS_INSTALL_DIR="${ESYSROOT}/usr"
- -DENABLE_WERROR=OFF
- )
- cmake_src_configure
-}
-
-multilib_src_install() {
- keepdir /etc/vulkan/icd.d
-
- cmake_src_install
-}