summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-07 20:39:22 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-07 20:40:34 -0700
commitf5c8b9272648d6eaecd6353972022836212d7cfb (patch)
treeb3ac0642777013b4a8ecb289e0aa7be1464e4155 /media-libs/waffle/waffle-1.6.1-r1.ebuild
parentsys-cluster/cephi-15.2.0-r1: revbump add dep on libfmt (bug #716592) (diff)
downloadgentoo-f5c8b9272648d6eaecd6353972022836212d7cfb.tar.gz
gentoo-f5c8b9272648d6eaecd6353972022836212d7cfb.tar.bz2
gentoo-f5c8b9272648d6eaecd6353972022836212d7cfb.zip
media-libs/waffle: Reapply patch to Generate WaffleConfig.cmake file
I mistakenly thought this was included in the 1.6.1 release. Closes: https://bugs.gentoo.org/716130 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/waffle/waffle-1.6.1-r1.ebuild')
-rw-r--r--media-libs/waffle/waffle-1.6.1-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/waffle/waffle-1.6.1-r1.ebuild b/media-libs/waffle/waffle-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..bb76a7df510b
--- /dev/null
+++ b/media-libs/waffle/waffle-1.6.1-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
+ GIT_ECLASS="git-r3"
+else
+ SRC_URI="https://gitlab.freedesktop.org/mesa/${PN}/-/raw/website/files/release/${P}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+inherit meson multilib-minimal ${GIT_ECLASS}
+
+DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
+HOMEPAGE="http://www.waffle-gl.org/ https://gitlab.freedesktop.org/mesa/waffle"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="doc +egl +gbm wayland X"
+RESTRICT="test" # gl_basic tests don't work when run from portage
+
+RDEPEND="
+ >=media-libs/mesa-9.1.6[egl?,gbm?,${MULTILIB_USEDEP}]
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
+ gbm? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.10[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=x11-base/xcb-proto-1.8-r3[${MULTILIB_USEDEP}]
+"
+BDEPEND="
+ dev-libs/libxslt
+ app-text/docbook-xml-dtd:4.2
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-meson-Generate-cmake-config-and-version-files-if-mes.patch
+)
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/wflinfo$(get_exeext)
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature X glx)
+ $(meson_feature wayland)
+ $(meson_feature X x11_egl)
+ $(meson_feature gbm)
+ $(meson_feature egl surfaceless_egl)
+ -Dbuild-manpages=true
+ -Dbuild-tests=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ ! use doc && rm -rf "${D}"/usr/share/doc/waffle1
+}