summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-08 11:39:32 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-08 12:33:09 -0700
commit7a9177eb6ef769dc342948c632b721426595ab41 (patch)
tree6076087b71868c9d4afbab63965d5302451d9b25 /media-libs/x265/x265-2.8.ebuild
parentsci-libs/volk: add comment for build_type (diff)
downloadgentoo-7a9177eb6ef769dc342948c632b721426595ab41.tar.gz
gentoo-7a9177eb6ef769dc342948c632b721426595ab41.tar.bz2
gentoo-7a9177eb6ef769dc342948c632b721426595ab41.zip
media-libs/x265: migrate to cpu_flags_ppc_vsx2 instead of power8
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'media-libs/x265/x265-2.8.ebuild')
-rw-r--r--media-libs/x265/x265-2.8.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/media-libs/x265/x265-2.8.ebuild b/media-libs/x265/x265-2.8.ebuild
index f4bb545314bb..3041c243b775 100644
--- a/media-libs/x265/x265-2.8.ebuild
+++ b/media-libs/x265/x265-2.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,7 +19,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/160"
-IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+IUSE="+10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_vsx2 numa pic test"
RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
@@ -143,8 +143,8 @@ multilib_src_configure() {
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
-DENABLE_LIBNUMA=$(usex numa ON OFF)
- -DCPU_POWER8=$(usex power8 ON OFF)
- -DENABLE_ALTIVEC=$(usex power8 ON OFF)
+ -DCPU_POWER8=$(usex cpu_flags_ppc_vsx2 ON OFF)
+ -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_vsx2 ON OFF)
-DLIB_INSTALL_DIR="$(get_libdir)"
)