summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-07 12:50:56 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-07 12:50:56 +0100
commitc0fa018451c60ed2c85417cc76a222d2a580f403 (patch)
treec5b08ea0f2e123055215100cf79bc12792666d48 /media-libs/x265
parentmedia-libs/x265: Use proper variable for en/disabling neon. (diff)
downloadgentoo-c0fa018451c60ed2c85417cc76a222d2a580f403.tar.gz
gentoo-c0fa018451c60ed2c85417cc76a222d2a580f403.tar.bz2
gentoo-c0fa018451c60ed2c85417cc76a222d2a580f403.zip
media-libs/x265: Disable arm assembly when requesting a PIC build, it is not PIC.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/x265')
-rw-r--r--media-libs/x265/x265-2.2.ebuild3
-rw-r--r--media-libs/x265/x265-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/media-libs/x265/x265-2.2.ebuild b/media-libs/x265/x265-2.2.ebuild
index a53a6c0caa95..21d6b90d3729 100644
--- a/media-libs/x265/x265-2.2.ebuild
+++ b/media-libs/x265/x265-2.2.ebuild
@@ -145,7 +145,8 @@ multilib_src_configure() {
# bug #510890
myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
elif [[ ${ABI} = arm ]] ; then
- myabicmakeargs+=( -DENABLE_ASSEMBLY=$(usex neon ON OFF) )
+ myabicmakeargs+=( -DENABLE_ASSEMBLY=$(usex pic OFF $(usex neon ON OFF)) )
+ use neon && use pic && ewarn "PIC has been requested but arm neon asm is not PIC-safe, disabling it."
fi
local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index 3e2490cd0219..96a02045099c 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -145,7 +145,8 @@ multilib_src_configure() {
# bug #510890
myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
elif [[ ${ABI} = arm ]] ; then
- myabicmakeargs+=( -DENABLE_ASSEMBLY=$(usex neon ON OFF) )
+ myabicmakeargs+=( -DENABLE_ASSEMBLY=$(usex pic OFF $(usex neon ON OFF)) )
+ use neon && use pic && ewarn "PIC has been requested but arm neon asm is not PIC-safe, disabling it."
fi
local MULTIBUILD_VARIANTS=( $(x265_get_variants) )