summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-12-19 02:21:44 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-12-19 04:09:35 +0100
commit8e3107911b2e096adf13d1ff420ab1d86970d678 (patch)
treed9ff04cd9d9bd42e354914d7014265e0a8e75273 /media-libs/xvid/xvid-1.3.5.ebuild
parentx11-drivers/xf86-video-vboxvideo: Move libpciaccess to RDEPEND (diff)
downloadgentoo-8e3107911b2e096adf13d1ff420ab1d86970d678.tar.gz
gentoo-8e3107911b2e096adf13d1ff420ab1d86970d678.tar.bz2
gentoo-8e3107911b2e096adf13d1ff420ab1d86970d678.zip
media-libs/xvid: Bump to version 1.3.5
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-libs/xvid/xvid-1.3.5.ebuild')
-rw-r--r--media-libs/xvid/xvid-1.3.5.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/xvid/xvid-1.3.5.ebuild b/media-libs/xvid/xvid-1.3.5.ebuild
new file mode 100644
index 000000000000..f0ddb60833ec
--- /dev/null
+++ b/media-libs/xvid/xvid-1.3.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic multilib multilib-minimal
+
+MY_PN="${PN}core"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XviD, a high performance/quality MPEG-4 video de-/encoding solution"
+HOMEPAGE="http://www.xvid.org/"
+SRC_URI="http://downloads.xvid.org/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples elibc_FreeBSD +threads pic"
+
+NASM=">=dev-lang/nasm-2"
+YASM=">=dev-lang/yasm-1"
+
+DEPEND="sys-apps/grep
+ amd64? ( || ( ${YASM} ${NASM} ) )
+ amd64-fbsd? ( ${NASM} )
+ x86? ( || ( ${YASM} ${NASM} ) )
+ x86-fbsd? ( ${NASM} )
+ x86-macos? ( ${NASM} )
+ x64-macos? ( ${NASM} )"
+RDEPEND="abi_x86_32? ( !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+
+S="${WORKDIR}/${MY_PN}/build/generic"
+
+src_prepare() {
+ default
+
+ # make build verbose
+ sed \
+ -e 's/@$(CC)/$(CC)/' \
+ -e 's/@$(AS)/$(AS)/' \
+ -e 's/@$(RM)/$(RM)/' \
+ -e 's/@$(INSTALL)/$(INSTALL)/' \
+ -e 's/@cd/cd/' \
+ -i Makefile || die
+ # Since only the build system is in $S, this will only copy it but not the
+ # entire sources.
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ use sparc && append-cflags -mno-vis #357149
+ use elibc_FreeBSD && export ac_cv_prog_ac_yasm=no #477736
+
+ local myconf=( $(use_enable threads pthread) )
+ if use pic || [[ ${ABI} == "x32" ]] ; then #421841
+ myconf+=( --disable-assembly )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ dodoc "${S}"/../../{AUTHORS,ChangeLog*,CodingStyle,README,TODO}
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r "${S}"/../../examples
+ fi
+}