summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-14 15:07:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-14 15:07:44 +0200
commite761336ced614434bfa56fe6f96fd1e76b196306 (patch)
tree88bec33af3b57c8220a3e3103d0b35d61105d80c /media-libs/zimg/zimg-2.3.ebuild
parentdev-ros/rosserial_server: backport upstream patch to build with boost 1.62, b... (diff)
downloadgentoo-e761336ced614434bfa56fe6f96fd1e76b196306.tar.gz
gentoo-e761336ced614434bfa56fe6f96fd1e76b196306.tar.bz2
gentoo-e761336ced614434bfa56fe6f96fd1e76b196306.zip
media-libs/zimg: bump to 2.3
Package-Manager: portage-2.3.2
Diffstat (limited to 'media-libs/zimg/zimg-2.3.ebuild')
-rw-r--r--media-libs/zimg/zimg-2.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/zimg/zimg-2.3.ebuild b/media-libs/zimg/zimg-2.3.ebuild
new file mode 100644
index 000000000000..a8a8647561d2
--- /dev/null
+++ b/media-libs/zimg/zimg-2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ autotools-multilib_src_configure \
+ $(use_enable cpu_flags_x86_sse x86simd)
+}