summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-05-22 13:32:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-05-23 13:03:38 +0200
commitdeb74b91a6a63ca52146942b8d0b4118a5c4e167 (patch)
tree8a92ad8a81193095979242866521c749ab20f8c7 /media-libs/zimg/zimg-2.8.ebuild
parentnet-mail/qmail-autoresponder: bump version to 2.0 (diff)
downloadgentoo-deb74b91a6a63ca52146942b8d0b4118a5c4e167.tar.gz
gentoo-deb74b91a6a63ca52146942b8d0b4118a5c4e167.tar.bz2
gentoo-deb74b91a6a63ca52146942b8d0b4118a5c4e167.zip
media-libs/zimg: bump to 2.8
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs/zimg/zimg-2.8.ebuild')
-rw-r--r--media-libs/zimg/zimg-2.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/zimg/zimg-2.8.ebuild b/media-libs/zimg/zimg-2.8.ebuild
new file mode 100644
index 000000000000..d20d4bf58406
--- /dev/null
+++ b/media-libs/zimg/zimg-2.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+inherit autotools multilib-minimal
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable cpu_flags_x86_sse x86simd)
+}