summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/zita-alsa-pcmi/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/zita-alsa-pcmi/files')
-rw-r--r--media-libs/zita-alsa-pcmi/files/makefile.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/media-libs/zita-alsa-pcmi/files/makefile.patch b/media-libs/zita-alsa-pcmi/files/makefile.patch
new file mode 100644
index 000000000000..d5e86d6c68f5
--- /dev/null
+++ b/media-libs/zita-alsa-pcmi/files/makefile.patch
@@ -0,0 +1,65 @@
+Index: zita-alsa-pcmi-0.2.0/libs/Makefile
+===================================================================
+--- zita-alsa-pcmi-0.2.0.orig/libs/Makefile
++++ zita-alsa-pcmi-0.2.0/libs/Makefile
+@@ -31,7 +31,7 @@ VERSION = $(MAJVERS).$(MINVERS)
+
+
+ CPPFLAGS += -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS
+-CXXFLAGS += -O2 -Wall -I. -fPIC
++CXXFLAGS += -Wall -I. -fPIC
+ LDLFAGS +=
+ LDLIBS +=
+
+@@ -45,14 +45,14 @@ ZITA-ALSA-PCMI_H = zita-alsa-pcmi.h
+
+
+ $(ZITA-ALSA-PCMI_MIN): $(ZITA-ALSA-PCMI_O)
+- g++ -shared $(LDFLAGS) -Wl,-soname,$(ZITA-ALSA-PCMI_MAJ) -o $(ZITA-ALSA-PCMI_MIN) $(ZITA-ALSA-PCMI_O) $(ZITA-ALSA-PCMI_DEP)
++ $(CXX) -shared $(LDFLAGS) -Wl,-soname,$(ZITA-ALSA-PCMI_MAJ) -o $(ZITA-ALSA-PCMI_MIN) $(ZITA-ALSA-PCMI_O) $(ZITA-ALSA-PCMI_DEP)
+
+
+ install: $(ZITA-ALSA-PCMI_MIN)
+ install -Dm 644 $(ZITA-ALSA-PCMI_H) $(DESTDIR)$(PREFIX)/include/$(ZITA-ALSA-PCMI_H)
+ install -Dm 644 $(ZITA-ALSA-PCMI_MIN) $(DESTDIR)$(PREFIX)/$(LIBDIR)/$(ZITA-ALSA-PCMI_MIN)
+ ln -sf $(ZITA-ALSA-PCMI_MIN) $(DESTDIR)$(PREFIX)/$(LIBDIR)/$(ZITA-ALSA-PCMI_SO)
+- ldconfig
++ ln -sf $(ZITA-ALSA-PCMI_MIN) $(DESTDIR)$(PREFIX)/$(LIBDIR)/$(ZITA-ALSA-PCMI_MAJ)
+
+ uninstall:
+ rm -rf $(DESTDIR)$(PREFIX)/include/zita-alsa-pcmi.h
+Index: zita-alsa-pcmi-0.2.0/apps/Makefile
+===================================================================
+--- zita-alsa-pcmi-0.2.0.orig/apps/Makefile
++++ zita-alsa-pcmi-0.2.0/apps/Makefile
+@@ -23,9 +23,9 @@ PREFIX = /usr/local
+ SUFFIX := $(shell uname -m | sed -e 's/^unknown/$//' -e 's/^i.86/$//' -e 's/^x86_64/$/64/')
+ LIBDIR = lib$(SUFFIX)
+ VERSION = "0.1.0"
+-LDFLAGS += -L$(PREFIX)/$(LIBDIR)
+-CPPFLAGS += -DVERSION=\"$(VERSION)\"
+-CXXFLAGS += -O2 -Wall -MMD -MP
++LDFLAGS += -L$(PREFIX)/$(LIBDIR) -L../libs/
++CPPFLAGS += -DVERSION=\"$(VERSION)\" -I../libs/
++CXXFLAGS += -Wall -MMD -MP
+
+
+ all: alsa_loopback alsa_delay
+@@ -34,7 +34,7 @@ all: alsa_loopback alsa_delay
+ ALSA_LOOPBACK_O = alsa_loopback.o pxthread.o
+ alsa_loopback: LDLIBS += -lzita-alsa-pcmi -lasound -lpthread -lrt
+ alsa_loopback: $(ALSA_LOOPBACK_O)
+- g++ $(LDFLAGS) -o $@ $(ALSA_LOOPBACK_O) $(LDLIBS)
++ $(CXX) $(LDFLAGS) -o $@ $(ALSA_LOOPBACK_O) $(LDLIBS)
+ $(ALSA_LOOPBACK_O):
+ -include $(_ALSA_LOOPBACK_O:%.o=%.d)
+
+@@ -42,7 +42,7 @@ $(ALSA_LOOPBACK_O):
+ ALSA_DELAY_O = alsa_delay.o mtdm.o pxthread.o
+ alsa_delay: LDLIBS += -lzita-alsa-pcmi -lasound -lpthread -lrt
+ alsa_delay: $(ALSA_DELAY_O)
+- g++ $(LDFLAGS) -o $@ $(ALSA_DELAY_O) $(LDLIBS)
++ $(CXX) $(LDFLAGS) -o $@ $(ALSA_DELAY_O) $(LDLIBS)
+ $(ALSA_DELAY_O):
+ -include $(ALSA_DELAY_O:%.o=%.d)
+