summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-05-25 21:35:49 +0200
committerAmy Liffey <amynka@gentoo.org>2018-05-25 21:35:49 +0200
commit002d99b2bfde3f4dfc53c79087b6367ee2cf704d (patch)
treec7408c811de06e910d5d7cf507fe29b3a616fd2a /media-libs
parentmedia-libs/opencv: drop old 3.1.0 (diff)
downloadgentoo-002d99b2bfde3f4dfc53c79087b6367ee2cf704d.tar.gz
gentoo-002d99b2bfde3f4dfc53c79087b6367ee2cf704d.tar.bz2
gentoo-002d99b2bfde3f4dfc53c79087b6367ee2cf704d.zip
media-libs/opencv: remove unused patches
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/opencv/files/opencv-3.1.0-cmake-no-opengl.patch22
-rw-r--r--media-libs/opencv/files/opencv-3.1.0-git-autodetect.patch42
-rw-r--r--media-libs/opencv/files/opencv-3.1.0-remove-graphcut-for-cuda-8.patch23
3 files changed, 0 insertions, 87 deletions
diff --git a/media-libs/opencv/files/opencv-3.1.0-cmake-no-opengl.patch b/media-libs/opencv/files/opencv-3.1.0-cmake-no-opengl.patch
deleted file mode 100644
index d6d70d717d3b..000000000000
--- a/media-libs/opencv/files/opencv-3.1.0-cmake-no-opengl.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From cdb9c60dcb65e04e7c0bd6bef9b86841191c785a Mon Sep 17 00:00:00 2001
-From: Alexander Alekhin <alexander.alekhin@itseez.com>
-Date: Thu, 31 Dec 2015 02:24:54 +0300
-Subject: [PATCH] gpu samples: fix REMOVE_ITEM error
-
----
- samples/gpu/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/samples/gpu/CMakeLists.txt b/samples/gpu/CMakeLists.txt
-index 6085cac..852a8c2 100644
---- a/samples/gpu/CMakeLists.txt
-+++ b/samples/gpu/CMakeLists.txt
-@@ -97,7 +97,7 @@ endif()
- if(INSTALL_C_EXAMPLES AND NOT WIN32)
- file(GLOB install_list *.c *.cpp *.jpg *.png *.data makefile.* build_all.sh *.dsp *.cmd )
- if(NOT WITH_OPENGL)
-- list(REMOVE_ITEM all_samples "opengl.cpp")
-+ list(REMOVE_ITEM install_list "opengl.cpp")
- endif(NOT WITH_OPENGL)
- install(FILES ${install_list}
- DESTINATION ${OPENCV_SAMPLES_SRC_INSTALL_PATH}/gpu
diff --git a/media-libs/opencv/files/opencv-3.1.0-git-autodetect.patch b/media-libs/opencv/files/opencv-3.1.0-git-autodetect.patch
deleted file mode 100644
index f4bf0da2cc92..000000000000
--- a/media-libs/opencv/files/opencv-3.1.0-git-autodetect.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- a/CMakeLists.txt 2016-04-07 14:34:35.090937125 +0200
-+++ b/CMakeLists.txt 2016-04-07 14:35:18.492935300 +0200
-@@ -444,23 +444,23 @@
- # ----------------------------------------------------------------------------
- # Autodetect if we are in a GIT repository
- # ----------------------------------------------------------------------------
--find_host_package(Git QUIET)
-+#find_host_package(Git QUIET)
-
--if(GIT_FOUND)
-- execute_process(COMMAND "${GIT_EXECUTABLE}" describe --tags --always --dirty --match "[0-9].[0-9].[0-9]*"
-- WORKING_DIRECTORY "${OpenCV_SOURCE_DIR}"
-- OUTPUT_VARIABLE OPENCV_VCSVERSION
-- RESULT_VARIABLE GIT_RESULT
-- ERROR_QUIET
-- OUTPUT_STRIP_TRAILING_WHITESPACE
-- )
-- if(NOT GIT_RESULT EQUAL 0)
-- set(OPENCV_VCSVERSION "unknown")
-- endif()
--else()
-- # We don't have git:
-- set(OPENCV_VCSVERSION "unknown")
--endif()
-+#if(GIT_FOUND)
-+# execute_process(COMMAND "${GIT_EXECUTABLE}" describe --tags --always --dirty --match "[0-9].[0-9].[0-9]*"
-+# WORKING_DIRECTORY "${OpenCV_SOURCE_DIR}"
-+# OUTPUT_VARIABLE OPENCV_VCSVERSION
-+# RESULT_VARIABLE GIT_RESULT
-+# ERROR_QUIET
-+# OUTPUT_STRIP_TRAILING_WHITESPACE
-+# )
-+# if(NOT GIT_RESULT EQUAL 0)
-+# set(OPENCV_VCSVERSION "unknown")
-+# endif()
-+#else()
-+# # We don't have git:
-+# set(OPENCV_VCSVERSION "unknown")
-+#endif()
-
-
- # ----------------------------------------------------------------------------
diff --git a/media-libs/opencv/files/opencv-3.1.0-remove-graphcut-for-cuda-8.patch b/media-libs/opencv/files/opencv-3.1.0-remove-graphcut-for-cuda-8.patch
deleted file mode 100644
index 64761a263a17..000000000000
--- a/media-libs/opencv/files/opencv-3.1.0-remove-graphcut-for-cuda-8.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 10896129b39655e19e4e7c529153cb5c2191a1db Mon Sep 17 00:00:00 2001
-From: Vladislav Vinogradov <vlad.vinogradov@itseez.com>
-Date: Fri, 6 May 2016 11:37:32 +0300
-Subject: [PATCH] GraphCut deprecated in CUDA 7.5 and removed in 8.0
-
----
- modules/cudalegacy/src/graphcuts.cpp | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/modules/cudalegacy/src/graphcuts.cpp b/modules/cudalegacy/src/graphcuts.cpp
-index eb08c3c..1a1eb85 100644
---- a/modules/cudalegacy/src/graphcuts.cpp
-+++ b/modules/cudalegacy/src/graphcuts.cpp
-@@ -42,7 +42,8 @@
-
- #include "precomp.hpp"
-
--#if !defined (HAVE_CUDA) || defined (CUDA_DISABLER)
-+// GraphCut has been removed in NPP 8.0
-+#if !defined (HAVE_CUDA) || defined (CUDA_DISABLER) || (CUDART_VERSION >= 8000)
-
- void cv::cuda::graphcut(GpuMat&, GpuMat&, GpuMat&, GpuMat&, GpuMat&, GpuMat&, GpuMat&, Stream&) { throw_no_cuda(); }
- void cv::cuda::graphcut(GpuMat&, GpuMat&, GpuMat&, GpuMat&, GpuMat&, GpuMat&, GpuMat&, GpuMat&, GpuMat&, GpuMat&, GpuMat&, Stream&) { throw_no_cuda(); }