summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-03-09 14:59:08 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-03-09 15:04:54 +0100
commit01fad02386d827dca9e94a179753fd0cdabf2135 (patch)
tree2ec79a6819aafab4efb5618a7bc63d8abe041471 /media-libs
parentsci-libs/ignition-math: bump to 6.10.0 (diff)
downloadgentoo-01fad02386d827dca9e94a179753fd0cdabf2135.tar.gz
gentoo-01fad02386d827dca9e94a179753fd0cdabf2135.tar.bz2
gentoo-01fad02386d827dca9e94a179753fd0cdabf2135.zip
media-libs/zimg: bump to 3.0.3
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/zimg/Manifest1
-rw-r--r--media-libs/zimg/zimg-3.0.3.ebuild32
-rw-r--r--media-libs/zimg/zimg-9999.ebuild4
3 files changed, 35 insertions, 2 deletions
diff --git a/media-libs/zimg/Manifest b/media-libs/zimg/Manifest
index c65862038c88..81c202b64d8d 100644
--- a/media-libs/zimg/Manifest
+++ b/media-libs/zimg/Manifest
@@ -1,3 +1,4 @@
DIST zimg-2.9.2.tar.gz 266049 BLAKE2B 214a6afec061dc7cc7c751f2a57e56951e44b78fea6a0c0dc71235d3dd286fb811303b0a5198ab82165ee78d993caabaf39d7ec17db4c4e5ffca9a3475b49781 SHA512 b688f8e93a2e4549f2c844cd58c6e0714e6494d6fc8c800dc1b0cdf2278fb9925a646fc332350c1b5d77cef2134bf35e18a873c24ea1979c1adce57bfef68ebe
DIST zimg-3.0.1.tar.gz 326304 BLAKE2B 353e623520df49122badd2d58400936fd25bf74fe386ade6b7a5c1b86db696dd50ff72ff40e1edbd38ee9a8a10dd429f207061fdb2ea326018396dfb92707053 SHA512 ae117399772d2c35ffa61b8cf5d156edf4ed65e9ffeb2e9e0688c88244fdd1a89c098bd842e3795b33fb0951da97f844fb6ffe27045e3234720f70f842356936
DIST zimg-3.0.2.tar.gz 326554 BLAKE2B 2ebea0060519a6912caf685ec551ed60f64f3e379629c607ad21d256daa549a2e85e2c8dbc0886846e9636508576680ed60353d569aef407879ba5fa7dd3001d SHA512 6aed45c19a07862d389dfc2903a7ed9c0c6b6faa23e1d5de5483f15f1c3fb44a31c954004b8b9f34def0d387a43590d9403d9e24a99a271bcadc373c6ce30d42
+DIST zimg-3.0.3.tar.gz 326585 BLAKE2B 30ef9063d05869a718ba450e2733dede74abb3f60ca827bba683cc1c21f7c4521c830089e800a2f704bb7a133514b00fbd245362765d07811dcb4d2970b28d09 SHA512 859c625599b412ecdd72c73d7618f6c7f9760337f7c8aec69fb97e30e1e65e4da51f6cbc5a2c8ad58cb7fbccdccb5322b95f24166c0204da6a3a8cd862cfb2ab
diff --git a/media-libs/zimg/zimg-3.0.3.ebuild b/media-libs/zimg/zimg-3.0.3.ebuild
new file mode 100644
index 000000000000..2c7c54c43cfe
--- /dev/null
+++ b/media-libs/zimg/zimg-3.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+inherit autotools multilib-minimal
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="debug static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
diff --git a/media-libs/zimg/zimg-9999.ebuild b/media-libs/zimg/zimg-9999.ebuild
index 306320548ba3..2c7c54c43cfe 100644
--- a/media-libs/zimg/zimg-9999.ebuild
+++ b/media-libs/zimg/zimg-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,7 +8,7 @@ if [[ ${PV} = *9999* ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
S="${WORKDIR}/${PN}-release-${PV}/"
fi
inherit autotools multilib-minimal