summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <g.dartiguelongue@lexfo.fr>2016-01-31 14:58:59 +0100
committerGilles Dartiguelongue <g.dartiguelongue@lexfo.fr>2016-01-31 15:44:47 +0100
commit08452f907ffce426bf48bb841d35f86ed186b3a2 (patch)
tree5d07c7eb65aea564ca1c63b7195700eeb45308a5 /media-libs
parentdev-ruby/warden: add 1.2.5 (diff)
downloadgentoo-08452f907ffce426bf48bb841d35f86ed186b3a2.tar.gz
gentoo-08452f907ffce426bf48bb841d35f86ed186b3a2.tar.bz2
gentoo-08452f907ffce426bf48bb841d35f86ed186b3a2.zip
media-libs/gst-plugins-bad: version bump to 1.6.3
Package-Manager: portage-2.2.27
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins-bad/Manifest1
-rw-r--r--media-libs/gst-plugins-bad/gst-plugins-bad-1.6.3.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-bad/Manifest b/media-libs/gst-plugins-bad/Manifest
index bd33284ee494..99b9d02ba956 100644
--- a/media-libs/gst-plugins-bad/Manifest
+++ b/media-libs/gst-plugins-bad/Manifest
@@ -2,3 +2,4 @@ DIST gst-plugins-bad-0.10.23-h264-patches.tar.xz 5284 SHA256 40890e4d7792d1b4e18
DIST gst-plugins-bad-0.10.23.tar.xz 3155044 SHA256 03cf0786391c64625569072e904082a08861f05a63d64b2f8e8dad3f26d81bf9 SHA512 6437dd12707ef29651f4014b54612cf2a3a42ed4e05a1c5f4a432d80e27efd2abc0df891ebcfdc9e7b2cf9f71a15b88e48b3aa6db24a178ed6de3b1bdf4c3dc4 WHIRLPOOL dd657100909c32ab75cb8aada8db24d68ddf7a10dc0eb055982d7e4d9ae7a50c364eeac9017cea8b176734fc09cf7f8e4e8f52d24e3173806633ddb8a7acd93c
DIST gst-plugins-bad-1.4.5.tar.xz 3824936 SHA256 152fad7250683d72f9deb36c5685428338365fe4a4c87ffe15e38783b14f983c SHA512 65d6be58957b1329420611b8e6f1eb9869420745d9165047631cdf9e45083605f37dcfaf68a288fe4252f1b3543f7f70ded9c12eab2e0ac4ac9f4c4ce9eaac7a WHIRLPOOL f5ade3f101ca82b52e7145e5ac16f5c1ab5d042415ee7753586dc6ad0942467c4c5b5b4aa6b0bc44e1ebd9c40de1964df265aa41599cb692fd32aab2b6a7acf7
DIST gst-plugins-bad-1.6.2.tar.xz 4187644 SHA256 650855e39ff56a8bb6cb0c192109c5926ce12f536d06e19ebf829de71ef396fe SHA512 f2d14d32047440a64daf341f9538fcb37c8b808d5ba19e8e9d4b7f9439b77f81cfc791e72193cb69f280a038162921bc9670cc340905850bec656ed4fe488fb5 WHIRLPOOL 7ae8e20c706f3526a5cdd5b4d086dfcf86af4f93e6ba0d60f655c211ca41b80c841004d0fc2134ad3f77c3600913dff0d94610dc5751acbbc4b9305c5600e8dc
+DIST gst-plugins-bad-1.6.3.tar.xz 4216940 SHA256 971b29101d6a9c5e3fe94d99d977a227f58f0b2d29b6ca2c7f292052542b3a61 SHA512 0a3a1d3617f167e69c20db3fccf7af0c4983b8012136093dcc3d08c059d0d8687cf921309c91f94afb250e0c3b9f9ff397a98ff548ca83dc12ae762119ffc915 WHIRLPOOL eb1f1376ee9b36da09f93b14d587169a007578f7cfdce3981ae905638c28f32b85a2f2667fc347f0b9ff4aaa51512f9726377c9ab3c73040886eab9a09833612
diff --git a/media-libs/gst-plugins-bad/gst-plugins-bad-1.6.3.ebuild b/media-libs/gst-plugins-bad/gst-plugins-bad-1.6.3.ebuild
new file mode 100644
index 000000000000..d9f8dafa274f
--- /dev/null
+++ b/media-libs/gst-plugins-bad/gst-plugins-bad-1.6.3.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GST_ORG_MODULE="gst-plugins-bad"
+
+inherit eutils flag-o-matic gstreamer virtualx
+
+DESCRIPTION="Less plugins for GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+
+IUSE="X egl gles2 gtk +introspection opengl +orc vcd vnc wayland"
+REQUIRED_USE="
+ egl? ( !gles2 )
+ gles2? ( !egl !opengl )
+ opengl? ( X )
+ wayland? ( egl )
+"
+
+# dtmf plugin moved from bad to good in 1.2
+# X11 is automagic for now, upstream #709530
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+
+ egl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
+ gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
+ opengl? (
+ >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}] )
+ X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
+ wayland? ( dev-libs/wayland[${MULTILIB_USEDEP}] )
+
+ gtk? ( >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}] )
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+
+ !<media-libs/gst-plugins-good-1.1:${SLOT}
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_prepare() {
+ # FIXME: tests are slower than upstream expects
+ sed -e 's:/\* tcase_set_timeout.*:tcase_set_timeout (tc_chain, 5 * 60);:' \
+ -i tests/check/elements/audiomixer.c || die
+}
+
+multilib_src_configure() {
+ local myconf=()
+ if use opengl || use gles2 ; then
+ # Actually enable the gl element, not just libs
+ myconf+=( --enable-gl )
+ fi
+
+ # Always enable gsettings (no extra dependency)
+ # and shm (need a switch for winnt ?)
+ gstreamer_multilib_src_configure \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable egl) \
+ $(use_enable gles2) \
+ $(use_enable gtk gtk3) \
+ $(use_enable opengl) \
+ $(use_enable opengl glx) \
+ $(use_enable orc) \
+ $(use_enable vcd) \
+ $(use_enable vnc librfb) \
+ $(use_enable wayland) \
+ $(use_enable X x11) \
+ --disable-examples \
+ --disable-debug \
+ --disable-cocoa \
+ --disable-wgl \
+ --enable-shm \
+ ${myconf[$@]}
+ # not ported
+ # --enable-gsettings
+
+ if multilib_is_native_abi; then
+ local x
+ for x in libs plugins; do
+ ln -s "${S}"/docs/${x}/html docs/${x}/html || die
+ done
+ fi
+}
+
+multilib_src_test() {
+ unset DISPLAY
+ # FIXME: tests are slower than upstream expects
+ Xemake check -j1
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}