summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-19 23:36:04 +0000
committerSam James <sam@gentoo.org>2022-03-19 23:36:04 +0000
commit08678a03291385bf261453b46bc348090ded3ae7 (patch)
treed1883c0db0490fa0b9d64e6475e80b77295e62ea /media-libs
parentmedia-libs/urt: [QA] fix tc-get* quoting (diff)
downloadgentoo-08678a03291385bf261453b46bc348090ded3ae7.tar.gz
gentoo-08678a03291385bf261453b46bc348090ded3ae7.tar.bz2
gentoo-08678a03291385bf261453b46bc348090ded3ae7.zip
media-libs/osl: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/osl/osl-1.11.16.0-r2.ebuild4
-rw-r--r--media-libs/osl/osl-1.12.4.1-r2.ebuild2
2 files changed, 3 insertions, 3 deletions
diff --git a/media-libs/osl/osl-1.11.16.0-r2.ebuild b/media-libs/osl/osl-1.11.16.0-r2.ebuild
index 3dd9f84f2cf7..fe9c14961b1f 100644
--- a/media-libs/osl/osl-1.11.16.0-r2.ebuild
+++ b/media-libs/osl/osl-1.11.16.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -86,7 +86,7 @@ src_configure() {
# If no CPU SIMDs were used, completely disable them
[[ -z ${mysimd} ]] && mysimd=("0")
- local gcc=$(tc-getCC)
+ local gcc="$(tc-getCC)"
local mycmakeargs=(
# LLVM 10+ needs C++14
diff --git a/media-libs/osl/osl-1.12.4.1-r2.ebuild b/media-libs/osl/osl-1.12.4.1-r2.ebuild
index 8678e5483bcb..b04804eadb45 100644
--- a/media-libs/osl/osl-1.12.4.1-r2.ebuild
+++ b/media-libs/osl/osl-1.12.4.1-r2.ebuild
@@ -82,7 +82,7 @@ src_configure() {
# If no CPU SIMDs were used, completely disable them
[[ -z ${mysimd} ]] && mysimd=("0")
- local gcc=$(tc-getCC)
+ local gcc="$(tc-getCC)"
# LLVM needs CPP11. Do not disable.
local mycmakeargs=(
-DCMAKE_CXX_STANDARD=14