summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-18 09:08:33 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-18 09:08:33 +0200
commit0eae00fa665273381016576ad8b427d4d22edebe (patch)
treeca6abff984f701960e75dbcc2d1bc561218bbbf2 /media-libs
parentgames-fps/urbanterror-data: Missing || die (diff)
downloadgentoo-0eae00fa665273381016576ad8b427d4d22edebe.tar.gz
gentoo-0eae00fa665273381016576ad8b427d4d22edebe.tar.bz2
gentoo-0eae00fa665273381016576ad8b427d4d22edebe.zip
media-libs/harfbuzz: Bump to version 1.8.4
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-1.8.4.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index 7cda4ec101dc..925475e0922b 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -2,3 +2,4 @@ DIST harfbuzz-1.7.6.tar.bz2 2586909 BLAKE2B 0ae5902b9fe00a4f05a5dc407d6981959204
DIST harfbuzz-1.8.1.tar.bz2 3804867 BLAKE2B 9687b35bbdb74a42c28764a7b026a46ff90640b84bc40702bdbfadc79bbe3c393de837d4cdbbb8798f28aa8c75687c4f07e1c79e98bf9bd506403d89b4baf6a5 SHA512 7ef27232b294883b0c7404c8412837acfba95f12677f226d764f87e22cd169fe037e7bf13a9309e78c9aa905225fb332b3a143a01b13308b05fcccaeddb0c931
DIST harfbuzz-1.8.2.tar.bz2 3820498 BLAKE2B 7ed1509a7b54571e14d72fa097d19a56e27b3c0020243e51315ff783910319486e6c1af7cec88060c17ccf5788ff1b09f26ee4dbc879b009c983ede767e00316 SHA512 c88a3e9e55866608647318a1af7c5d848863cd894d635583b8a2d2a7a02eea875b7a5a4f0f38555d80f2e81628743e40710f5e6f9251bf629f1d15ac51103e5a
DIST harfbuzz-1.8.3.tar.bz2 3828043 BLAKE2B 038a714480f10b05b2b31ba46667ce563598b43d122f64ab4adc6f267b2b99ea23ba92a1ae0df173be13f29da8960d55a5c5fdee25aa9fc4541a109c5e76946d SHA512 d3ec8f31ff51315fb35f6b5c69b3fbf29e1dff710fb11158801990fbeb99be5fce691f3c06df1c295a08bfb6c14021c511993b0d22ca96e76d8212ddfda198b6
+DIST harfbuzz-1.8.4.tar.bz2 3829479 BLAKE2B df4116945a00130b83198044665c4f0f0da497cf7d198a39632bbbe6b95327f8189dc7486262eb4d03b181c0151d89bea41223e092613c2f8fec9566eb6f9434 SHA512 8ec72b065b3f5d227b0af1486ab8019414bbdfaafce2f99d5a8bbf7d37a2709cadb545efcc46c5a5c44ce405966f01d8f3e8607f31907f8ed7ebe10150c9dcaf
diff --git a/media-libs/harfbuzz/harfbuzz-1.8.4.ebuild b/media-libs/harfbuzz/harfbuzz-1.8.4.ebuild
new file mode 100644
index 000000000000..c723137a7e55
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-1.8.4.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit flag-o-matic libtool multilib-minimal python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/harfbuzz.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+fi
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+
+IUSE="+cairo debug fontconfig +glib +graphite icu +introspection static-libs test +truetype"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ fontconfig? ( media-libs/fontconfig:1.0[${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+"
+# eautoreconf requires gobject-introspection-common
+# ragel needed if regenerating *.hh files from *.rl
+if [[ ${PV} = 9999 ]] ; then
+ DEPEND+="
+ >=dev-libs/gobject-introspection-common-1.34
+ dev-util/ragel
+ "
+fi
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # on Darwin/Solaris we need to link with g++, like automake defaults
+ # to, but overridden by upstream because on Linux this is not
+ # necessary, bug #449126
+ sed -i \
+ -e 's/\<LINK\>/CXXLINK/' \
+ src/Makefile.am || die
+ sed -i \
+ -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
+ src/Makefile.in || die
+ sed -i \
+ -e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
+ test/api/Makefile.in || die
+ fi
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+ elibtoolize # for Solaris
+
+ # bug 618772
+ append-cxxflags -std=c++14
+}
+
+multilib_src_configure() {
+ # harfbuzz-gobject only used for instrospection, bug #535852
+ local myeconfargs=(
+ --without-coretext
+ --without-uniscribe
+ $(use_enable static-libs static)
+ $(multilib_native_use_with cairo)
+ $(use_with fontconfig)
+ $(use_with glib)
+ $(use_with introspection gobject)
+ $(use_with graphite graphite2)
+ $(use_with icu)
+ $(multilib_native_use_enable introspection)
+ $(use_with truetype freetype)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/html docs/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name "*.la" -delete || die
+}