summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-03-15 14:25:46 +0100
committerMichael Weber <xmw@gentoo.org>2016-03-15 14:48:16 +0100
commit15d93a8b6117761b2d22facdec67d66e14c90d6d (patch)
tree9a904c60cd0c7e9594790fc8dbc997736d6cd68e /media-libs
parentMerge remote-tracking branch 'remotes/github/pr/1054' (diff)
downloadgentoo-15d93a8b6117761b2d22facdec67d66e14c90d6d.tar.gz
gentoo-15d93a8b6117761b2d22facdec67d66e14c90d6d.tar.bz2
gentoo-15d93a8b6117761b2d22facdec67d66e14c90d6d.zip
media-libs/raspberrypi-userland-bin: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/raspberrypi-userland-bin/Manifest1
-rw-r--r--media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20160209.ebuild4
-rw-r--r--media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20160309.ebuild49
3 files changed, 52 insertions, 2 deletions
diff --git a/media-libs/raspberrypi-userland-bin/Manifest b/media-libs/raspberrypi-userland-bin/Manifest
index bacb97efe086..9fa4abf1b0d9 100644
--- a/media-libs/raspberrypi-userland-bin/Manifest
+++ b/media-libs/raspberrypi-userland-bin/Manifest
@@ -1 +1,2 @@
DIST raspberrypi-firmware-1.20160209.tar.gz 114792438 SHA256 ca6a88db72e90ef821b8ca7755bbee9c1d5bdb9a621a45eb029af195d2d29751 SHA512 281092c11d422d821e5e2b0479c3b8f891f8df66cfbf931992902d759c99ed40cbb2d9fada1f944372e5bcd8af69784739e79e9912db3482892b10bf668611f2 WHIRLPOOL 81974a53562ee91544d7a01dc9f4f4173a6e882891f8cf744b700162ddd8f8607b1cfcbbde04cafe2bcea47489f9ea4fd8840adf776e806bef0dba574448e76e
+DIST raspberrypi-firmware-1.20160309.tar.gz 115673896 SHA256 ead0e82b930fdeed9636a6d2d6e07b2512b5f36de3c902da5beaa9328708e181 SHA512 30a6396ef52355c6f6404354645e8d0f5bbf70332b0e1661dfa8ef3456154d07e105d3b7b5bd64efb3e7397fa2fb8c36de1aa78040dc4118060b26949c2ab884 WHIRLPOOL 19a2a28e7dc1403958f12338b5029187bb752f1367f9a46e217b3d91b098960f1cf75efb3610defe3bb2f521559019453cf50a52def3abb9c1ac61419b8ea328
diff --git a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20160209.ebuild b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20160209.ebuild
index b7b3c7b90cf9..036ebbce0156 100644
--- a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20160209.ebuild
+++ b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20160209.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
EAPI=5
diff --git a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20160309.ebuild b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20160309.ebuild
new file mode 100644
index 000000000000..036ebbce0156
--- /dev/null
+++ b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20160309.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib vcs-snapshot
+
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+MY_P="raspberrypi-firmware-${PV}"
+SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="~arm -*"
+IUSE="+hardfp examples"
+
+RDEPEND="!media-libs/raspberrypi-userland"
+DEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+RESTRICT="binchecks"
+
+src_prepare() {
+ rm {,hardfp/}opt/vc/LICENCE || die
+}
+
+src_install() {
+ cd $(usex hardfp hardfp/ "")opt/vc || die
+
+ insinto /opt/vc
+ doins -r include
+ into /opt
+ dobin bin/*
+ dobin sbin/*
+ insopts -m 0755
+ insinto "/opt/vc/$(get_libdir)"
+ doins -r lib/*
+
+ doenvd "${FILESDIR}"/04${PN}
+
+ if use examples ; then
+ insopts -m 0644
+ insinto /usr/share/doc/${PF}/examples
+ doins -r src/hello_pi
+ fi
+}