summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-21 11:20:35 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-21 11:22:40 +0100
commit3bd254b724c72d5d2af64c535f47c1d198f7f45b (patch)
tree8b6e506a4296e1e8350f84d2f06426d4b67dc27d /media-libs
parentmedia-libs/libdvdread: Synced live ebuild. (diff)
downloadgentoo-3bd254b724c72d5d2af64c535f47c1d198f7f45b.tar.gz
gentoo-3bd254b724c72d5d2af64c535f47c1d198f7f45b.tar.bz2
gentoo-3bd254b724c72d5d2af64c535f47c1d198f7f45b.zip
media-libs/libdvdnav: Bump to version 6.0.0
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libdvdnav/Manifest1
-rw-r--r--media-libs/libdvdnav/libdvdnav-6.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/libdvdnav/Manifest b/media-libs/libdvdnav/Manifest
index d727d7e2bfef..7ec21ea0cf21 100644
--- a/media-libs/libdvdnav/Manifest
+++ b/media-libs/libdvdnav/Manifest
@@ -1 +1,2 @@
DIST libdvdnav-5.0.3.tar.bz2 372203 BLAKE2B 82b935157cb59c14c0dc2ce043027dca43d181b1dc24435a4876310b4edb9961da96b202c6e99b6531fce22aa05dda2352cdbcfa42ab47051e533ca3fd458158 SHA512 d6d0519f654649bd65b3029224191e7d6acc893d94e8578e435d77b75327584e9f44410a062c1fc60c6211f5bea6b3971228d84de595808733ab7356980e0123
+DIST libdvdnav-6.0.0.tar.bz2 369605 BLAKE2B 911b786f1cf37d32b0516df9f3ae3c388ad352206e67f73f758984795459ced7507f1454747a205b64c2d1f42922ee26ee9d434499ceaf05053dfbeb4d7e52c7 SHA512 89d1e976d8f1cc92692e86e793403759b4d705682ba7418dcfd7dd3c38861238cead303fe4baa2059ebd7e9b82a77bbdbf32e50b20848e78939ee9e75d1b96d4
diff --git a/media-libs/libdvdnav/libdvdnav-6.0.0.ebuild b/media-libs/libdvdnav/libdvdnav-6.0.0.ebuild
new file mode 100644
index 000000000000..61b7dbaa549a
--- /dev/null
+++ b/media-libs/libdvdnav/libdvdnav-6.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Library for DVD navigation tools"
+HOMEPAGE="https://www.videolan.org/developers/libdvdnav.html"
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://code.videolan.org/videolan/libdvdnav.git"
+else
+ SRC_URI="https://downloads.videolan.org/pub/videolan/libdvdnav/${PV}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/libdvdread-5.0.3[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig" # To get pkg.m4 for eautoreconf #414391
+
+DOCS=( AUTHORS ChangeLog doc/dvd_structures doc/library_layout README TODO )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name "*.la" -delete || die
+}