summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-12-22 11:30:46 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-22 11:51:14 +0100
commit451789abdbf808a3b1424b69cc34283166320493 (patch)
treecb21bef546c4bba90dec3973029b513ccad628e9 /media-libs
parentx11-misc/ktsuss: remove the obsolete <description> tag (diff)
downloadgentoo-451789abdbf808a3b1424b69cc34283166320493.tar.gz
gentoo-451789abdbf808a3b1424b69cc34283166320493.tar.bz2
gentoo-451789abdbf808a3b1424b69cc34283166320493.zip
media-libs/alsa-lib: Bump to version 1.1.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alsa-lib/Manifest1
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.1.3.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/Manifest b/media-libs/alsa-lib/Manifest
index 9f7ab2c00910..27eb5eebc3d2 100644
--- a/media-libs/alsa-lib/Manifest
+++ b/media-libs/alsa-lib/Manifest
@@ -1,3 +1,4 @@
DIST alsa-lib-1.0.29.tar.bz2 905417 SHA256 73043c35eb9636be0f4af6a240235c213f12a25feb1f04aeeac8cb7e30fcbdd0 SHA512 c9c2dcd3105abadcfdff104770a1f7683d83f6b9df64eebe9f9efc1ecab3ca4cef43718b5b15526bdabf2862ce55ec665732bb0390fc8e6492e2c1cebec9294c WHIRLPOOL 330877960733e847c12f133f93acc58a2053303b4437c5aaf21e2c4df0c47389df28ed093ab6606ee3cb854389b359d981dc547fba08bab03cff1c99f93e72d8
DIST alsa-lib-1.1.1.tar.bz2 932105 SHA256 8ac76c3144ed2ed49da7622ab65ac5415205913ccbedde877972383cbc234269 SHA512 dacd0a74adc682ac0034cbeba2de3d1a141e0ac2e564c9e04dae202ffaf87ef3a1e01307afc2fd2d9cfe679e5b101c379f9b6ea5f7ccceeed14a427bd5232bc7 WHIRLPOOL c383ee51592e87c08a1bb25e358482afe6116b4feaf45121296fb887e77c930fb3b8e864f3265bf7bd4c57227fdcbc71994031bb9356621d69de7a252bed65a4
DIST alsa-lib-1.1.2.tar.bz2 947423 SHA256 d38dacd9892b06b8bff04923c380b38fb2e379ee5538935ff37e45b395d861d6 SHA512 a6c6675b1fd86955ef5072b9e6090795fc6b0b16f32481bece049e5f100e689be48b6416ff7cf36abfc67e0b94f420e08c15ff13a9701987d6bb69a8fa567e8a WHIRLPOOL 7aa68f305cb5ad58e9bdaeb3eee5fa7a37e9f606640789a9c778ff1bfd9b458d80e6ccfa9f73f9ad5b3a229ea988fa9b6d64b929c87f64ea9376a778f30eed0d
+DIST alsa-lib-1.1.3.tar.bz2 962001 SHA256 71282502184c592c1a008e256c22ed0ba5728ca65e05273ceb480c70f515969c SHA512 f5dbe2375a8c66af14378314a5238284d4ed63dfc86a750c0c6e8f6cdb6b1ea2d8ef26f870b5d152dc0b77d9b40821cab523f6734902b91583beb08e28c66850 WHIRLPOOL f33871789a7cc06a9db83fd659abdfeb7940d61a24ad7c71866f843d8c0c29eaf0e0770a2034dee2526c96835935b88c2fe882184c86528c98e7d4901f94b27d
diff --git a/media-libs/alsa-lib/alsa-lib-1.1.3.ebuild b/media-libs/alsa-lib/alsa-lib-1.1.3.ebuild
new file mode 100644
index 000000000000..ce747686f1d6
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.1.3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# no support for python3_2 or above yet wrt #471326
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils multilib multilib-minimal python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alisp debug doc elibc_uclibc python"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-soundlibs-20130224-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
+ # https://bugs.gentoo.org/509886
+ use elibc_uclibc && { sed -i -e 's:oldapi queue_timer:queue_timer:' test/Makefile.am || die; }
+ # https://bugs.gentoo.org/545950
+ sed -i -e '5s:^$:\nAM_CPPFLAGS = -I$(top_srcdir)/include:' test/lsb/Makefile.am || die
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf
+ # enable Python only on final ABI
+ if multilib_is_native_abi; then
+ myconf="$(use_enable python)"
+ else
+ myconf="--disable-python"
+ fi
+ use elibc_uclibc && myconf+=" --without-versioned"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-maintainer-mode \
+ --enable-shared \
+ --disable-resmgr \
+ --enable-rawmidi \
+ --enable-seq \
+ --enable-aload \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ ${myconf}
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ emake doc
+ fgrep -Zrl "${S}" doc/doxygen/html | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use doc; then
+ docinto html
+ dodoc -r doc/doxygen/html/.
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ find "${ED}"/usr/$(get_libdir)/alsa-lib -name '*.a' -exec rm -f {} +
+ docinto ""
+ dodoc ChangeLog doc/asoundrc.txt NOTES TODO
+}