summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-07-21 20:09:34 -0700
committerMatt Turner <mattst88@gentoo.org>2021-11-19 14:48:54 -0800
commit4dd59fa7fb6e80db150d9d754cda4fd43e2a594d (patch)
tree60d2bb862c580a647e6a305e10ce2e529cccc3c4 /media-libs
parentwww-client/vivaldi-snapshot: Set USE-defaults for mesa[egl,gbm] (diff)
downloadgentoo-4dd59fa7fb6e80db150d9d754cda4fd43e2a594d.tar.gz
gentoo-4dd59fa7fb6e80db150d9d754cda4fd43e2a594d.tar.bz2
gentoo-4dd59fa7fb6e80db150d9d754cda4fd43e2a594d.zip
media-libs/mesa: Remove IUSE=egl
Enabled by default for years. There's not a sensible reason to disable this while OpenGL is enabled (which it always is). Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 5829adce48f2..5f89824a189e 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -33,18 +33,16 @@ for card in ${VIDEO_CARDS}; do
done
IUSE="${IUSE_VIDEO_CARDS}
- +classic cpu_flags_x86_sse2 d3d9 debug +egl +gallium +gbm gles1 +gles2 +llvm
+ +classic cpu_flags_x86_sse2 d3d9 debug +gallium +gbm gles1 +gles2 +llvm
lm-sensors opencl osmesa selinux test unwind vaapi valgrind vdpau vulkan
vulkan-overlay wayland +X xa xvmc zink +zstd"
REQUIRED_USE="
d3d9? ( || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
- gles1? ( egl )
- gles2? ( egl )
osmesa? ( gallium )
vulkan? ( video_cards_radeonsi? ( llvm ) )
vulkan-overlay? ( vulkan )
- wayland? ( egl gbm )
+ wayland? ( gbm )
video_cards_crocus? ( gallium )
video_cards_freedreno? ( gallium )
video_cards_intel? ( classic )
@@ -384,12 +382,6 @@ multilib_src_configure() {
use wayland && platforms+=",wayland"
emesonargs+=(-Dplatforms=${platforms#,})
- if use X || use egl; then
- emesonargs+=(-Dglvnd=true)
- else
- emesonargs+=(-Dglvnd=false)
- fi
-
if use gallium; then
emesonargs+=(
$(meson_feature llvm)
@@ -512,7 +504,8 @@ multilib_src_configure() {
-Dglx=$(usex X dri disabled)
-Dshared-glapi=enabled
-Ddri3=enabled
- $(meson_feature egl)
+ -Degl=true
+ -Dglvnd=true
$(meson_feature gbm)
$(meson_feature gles1)
$(meson_feature gles2)