summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-05-26 15:01:19 +0200
committerDavid Seifert <soap@gentoo.org>2018-05-27 00:18:11 +0200
commit56b2e29cf87e35cf3f5b9c26b26f75a6cc2cfe1c (patch)
treeb124790220d6543e39036961471a566bdf320460 /media-libs
parentwww-apps/icingaweb2-module-graphite: fix SRC_URI for 1.0.1, EAPI=7 (diff)
downloadgentoo-56b2e29cf87e35cf3f5b9c26b26f75a6cc2cfe1c.tar.gz
gentoo-56b2e29cf87e35cf3f5b9c26b26f75a6cc2cfe1c.tar.bz2
gentoo-56b2e29cf87e35cf3f5b9c26b26f75a6cc2cfe1c.zip
media-libs/skstream: Force C++11
Closes: https://bugs.gentoo.org/651840 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/skstream/files/skstream-0.3.9-test.patch4
-rw-r--r--media-libs/skstream/skstream-0.3.9.ebuild15
2 files changed, 13 insertions, 6 deletions
diff --git a/media-libs/skstream/files/skstream-0.3.9-test.patch b/media-libs/skstream/files/skstream-0.3.9-test.patch
index 162d29d1fb53..b89aa3c0644e 100644
--- a/media-libs/skstream/files/skstream-0.3.9-test.patch
+++ b/media-libs/skstream/files/skstream-0.3.9-test.patch
@@ -1,5 +1,5 @@
---- test/childskstreamtest.h.old 2011-09-26 16:14:47.733708252 +0200
-+++ test/childskstreamtest.h 2011-09-26 16:16:32.021385992 +0200
+--- a/test/childskstreamtest.h
++++ b/test/childskstreamtest.h
@@ -109,9 +109,6 @@
//some macros for building the suite() method
CPPUNIT_TEST_SUITE(tcpskstreamtest);
diff --git a/media-libs/skstream/skstream-0.3.9.ebuild b/media-libs/skstream/skstream-0.3.9.ebuild
index 5a64f6452b82..0acc8b73db99 100644
--- a/media-libs/skstream/skstream-0.3.9.ebuild
+++ b/media-libs/skstream/skstream-0.3.9.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit base eutils
+EAPI=6
+
+inherit flag-o-matic
DESCRIPTION="FreeSockets - Portable C++ classes for IP (sockets) applications"
HOMEPAGE="http://www.worldforge.org/"
@@ -17,4 +18,10 @@ DEPEND="test? ( dev-util/cppunit )"
RDEPEND=""
PATCHES=( "${FILESDIR}"/${P}-test.patch )
-DOCS=( AUTHORS ChangeLog NEWS README README.FreeSockets TODO )
+
+src_configure() {
+ # bug 651840
+ append-cxxflags -std=c++11
+
+ default
+}