summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-18 16:59:31 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-18 16:59:36 +0100
commit7a0157f00cb58ec71860916ba7d97604e40459c0 (patch)
treec3cf47e4bccda856eee4d4df60b30ac75492d110 /media-libs
parentdev-python/pyee: bump to 1.0.2 (diff)
downloadgentoo-7a0157f00cb58ec71860916ba7d97604e40459c0.tar.gz
gentoo-7a0157f00cb58ec71860916ba7d97604e40459c0.tar.bz2
gentoo-7a0157f00cb58ec71860916ba7d97604e40459c0.zip
media-libs/chromaprint: bump to 1.3.1
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/chromaprint/Manifest1
-rw-r--r--media-libs/chromaprint/chromaprint-1.3.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/chromaprint/Manifest b/media-libs/chromaprint/Manifest
index fcdbdff6a0c2..e5de346b331c 100644
--- a/media-libs/chromaprint/Manifest
+++ b/media-libs/chromaprint/Manifest
@@ -1 +1,2 @@
DIST chromaprint-1.2.tar.gz 529646 SHA256 822b8949a322ac04c6f8a3ed78f5e689bcc493c6ca0972bf627c913c8430031a SHA512 dc61db8894a20df3d7e7317cd7cd97148c19be5854dd66409341cb8e47c045e1c632b254e14a869279983a5af2cc6f9effea21b77a63dff729511e6144439cbb WHIRLPOOL b2efb45c23e950b6a4d95c078bed15b03ef35e423b106428a7607034276b343b8c223ffa71e021846ed48f535663e062ae8042d281d769a04effc9afd8a600dd
+DIST chromaprint-1.3.1.tar.gz 538251 SHA256 8f95a011e6fe3a75281520daa9376b7f028300e20a5be9af08ef9c851d4bb581 SHA512 b900d9c94057354982c2c32b37d10bb8ac1b63d005ece1fe6aae38a037e18ea8e77c5e95faff51b8c725b3ff9f3551ab0ef2baf470b49952e5c3c3662da46aae WHIRLPOOL f0045dda0f5e3e29bdb9f2fc1a5ebe8922a7d976c351ca8d8ab817cc7ed6a026cf1b86732e5dda6a3cd1110281d5a0f3006cfb3e1c2f58adc8f9fc0cffc2fbce
diff --git a/media-libs/chromaprint/chromaprint-1.3.1.ebuild b/media-libs/chromaprint/chromaprint-1.3.1.ebuild
new file mode 100644
index 000000000000..12d082395a20
--- /dev/null
+++ b/media-libs/chromaprint/chromaprint-1.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-multilib
+
+DESCRIPTION="A client-side library that implements a custom algorithm for extracting fingerprints"
+HOMEPAGE="http://acoustid.org/chromaprint"
+SRC_URI="https://bitbucket.org/acoustid/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+IUSE="libav test tools"
+
+# note: use ffmpeg or libav instead of fftw because it's recommended and required for tools
+RDEPEND="
+ libav? ( >=media-video/libav-11:0=[${MULTILIB_USEDEP}] )
+ !libav? ( >=media-video/ffmpeg-2.6:0=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/gtest[${MULTILIB_USEDEP}]
+ dev-libs/boost[${MULTILIB_USEDEP}]
+ )"
+
+DOCS="NEWS.txt README.md"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.1-gtest.patch )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ "-DBUILD_EXAMPLES=$(multilib_native_usex tools ON OFF)"
+ "-DBUILD_TESTS=$(usex test ON OFF)"
+ -DWITH_AVFFT=ON
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_test() {
+ emake check
+}