summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-13 19:36:26 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-13 19:36:26 -0500
commit801e5a28b0f1ed8e3103d96cb17e4f222c5b57fd (patch)
tree78db3f861955c6a411386b79ae7891b2c3b3718d /media-libs
parentdev-util/lcov: drop old EAPI (diff)
downloadgentoo-801e5a28b0f1ed8e3103d96cb17e4f222c5b57fd.tar.gz
gentoo-801e5a28b0f1ed8e3103d96cb17e4f222c5b57fd.tar.bz2
gentoo-801e5a28b0f1ed8e3103d96cb17e4f222c5b57fd.zip
media-libs/libpostproc: drop old EAPI
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libpostproc/Manifest1
-rw-r--r--media-libs/libpostproc/libpostproc-0.8.0.20121125.ebuild87
-rw-r--r--media-libs/libpostproc/libpostproc-10.20140517.ebuild87
3 files changed, 0 insertions, 175 deletions
diff --git a/media-libs/libpostproc/Manifest b/media-libs/libpostproc/Manifest
index 1264acae3a5e..4f61e538f839 100644
--- a/media-libs/libpostproc/Manifest
+++ b/media-libs/libpostproc/Manifest
@@ -1,2 +1 @@
-DIST libpostproc-0.8.0.20121125.tar.xz 65376 BLAKE2B 7745fc0d495a3a6ea45f4e0b012f343d8db0838f7b26f778a646011e3ef01cdc8b7b37b1148b3ea4d838b3a51decb912a6b4328559929f6d38ab01ef8453f990 SHA512 7f1451dbe822d143793c12bb7c18fd9eeb98b5347bbfc54172f0aceb2f18cf31b2c0c888c33a9ce2e9f519b4bbb0a900b729188ce83cda9ad5499a8f6ea2d62a
DIST libpostproc-10.20140517.tar.xz 65556 BLAKE2B 374dc84fb52f32958bcf9daeaabf2be1405d444f72d1f1ccb22e42b657489adad55199e5be27fa80cdcc21ed4480bae901925fbd833bcd30625d82720d481800 SHA512 0d6dca077c99ac569d892bc92cd08c6bf3e3a5e30e623ced20227b5bd1bd1aa3ecd150bfc900659accd77b997eb64b4d6f0538f9b6161d190ef6c69dcaf47893
diff --git a/media-libs/libpostproc/libpostproc-0.8.0.20121125.ebuild b/media-libs/libpostproc/libpostproc-0.8.0.20121125.ebuild
deleted file mode 100644
index a6b424d6d4a7..000000000000
--- a/media-libs/libpostproc/libpostproc-0.8.0.20121125.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-2"
- EGIT_REPO_URI="https://github.com/dwbuiten/postproc.git"
-fi
-
-inherit eutils flag-o-matic multilib toolchain-funcs ${SCM}
-
-DESCRIPTION="Video post processing library"
-HOMEPAGE="https://github.com/dwbuiten/postproc"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
-elif [ "${PV%_p*}" != "${PV}" ] ; then # Snapshot
- SRC_URI="mirror://gentoo/${P}.tar.xz"
-else # Release
- SRC_URI="https://dev.gentoo.org/~lu_zero/distfiles/${P}.tar.xz"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-if [ "${PV#9999}" = "${PV}" ] ; then
- KEYWORDS="alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-fi
-IUSE="pic static-libs"
-
-# String for CPU features in the useflag[:configure_option] form
-# if :configure_option isn't set, it will use 'useflag' as configure option
-CPU_FEATURES="cpu_flags_x86_3dnow:amd3dnow altivec cpu_flags_x86_mmx:mmx cpu_flags_x86_mmxext:mmxext"
-for i in ${CPU_FEATURES}; do
- IUSE="${IUSE} ${i%:*}"
-done
-
-DEPEND=">=virtual/ffmpeg-0.10.2-r1"
-RDEPEND="${DEPEND}
- !<media-video/libav-0.8.2-r2
- !media-video/ffmpeg:0
-"
-
-src_configure() {
- local myconf="${EXTRA_LIBPOSTPROC_CONF}"
- for i in $(get-flag march) $(get-flag mcpu) $(get-flag mtune) ; do
- [ "${i}" = "native" ] && i="host" # bug #273421
- myconf="${myconf} --cpu=${i}"
- break
- done
-
- if use pic ; then
- myconf="${myconf} --enable-pic"
- # disable asm code if PIC is required
- # as the provided asm decidedly is not PIC for x86.
- use x86 && myconf="${myconf} --disable-asm"
- fi
-
- # cross compile support
- if tc-is-cross-compiler ; then
- myconf="${myconf} --enable-cross-compile --arch=$(tc-arch-kernel) --cross-prefix=${CHOST}-"
- case ${CHOST} in
- *freebsd*)
- myconf="${myconf} --target-os=freebsd"
- ;;
- mingw32*)
- myconf="${myconf} --target-os=mingw32"
- ;;
- *linux*)
- myconf="${myconf} --target-os=linux"
- ;;
- esac
- fi
-
- cd "${S}"
- ./configure \
- --prefix="${EPREFIX}/usr" \
- --libdir="${EPREFIX}/usr/$(get_libdir)" \
- --shlibdir="${EPREFIX}/usr/$(get_libdir)" \
- --enable-shared \
- --cc="$(tc-getCC)" \
- --ar="$(tc-getAR)" \
- --optflags="${CFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- $(use_enable static-libs static) \
- ${myconf} || die
-}
diff --git a/media-libs/libpostproc/libpostproc-10.20140517.ebuild b/media-libs/libpostproc/libpostproc-10.20140517.ebuild
deleted file mode 100644
index 38adba08f33d..000000000000
--- a/media-libs/libpostproc/libpostproc-10.20140517.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-2"
- EGIT_REPO_URI="https://github.com/lu-zero/postproc.git"
-fi
-
-inherit eutils flag-o-matic multilib toolchain-funcs ${SCM}
-
-DESCRIPTION="Video post processing library"
-HOMEPAGE="https://github.com/lu-zero/postproc"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
-elif [ "${PV%_p*}" != "${PV}" ] ; then # Snapshot
- SRC_URI="mirror://gentoo/${P}.tar.xz"
-else # Release
- SRC_URI="https://dev.gentoo.org/~lu_zero/distfiles/${P}.tar.xz"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-if [ "${PV#9999}" = "${PV}" ] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-IUSE="pic static-libs"
-
-# String for CPU features in the useflag[:configure_option] form
-# if :configure_option isn't set, it will use 'useflag' as configure option
-CPU_FEATURES="cpu_flags_x86_3dnow:amd3dnow altivec cpu_flags_x86_mmx:mmx cpu_flags_x86_mmxext:mmxext"
-for i in ${CPU_FEATURES}; do
- IUSE="${IUSE} ${i%:*}"
-done
-
-DEPEND=">=virtual/ffmpeg-0.10.2-r2"
-RDEPEND="${DEPEND}
- !<media-video/libav-0.8.2-r2
- !media-video/ffmpeg:0
-"
-
-src_configure() {
- local myconf="${EXTRA_LIBPOSTPROC_CONF}"
- for i in $(get-flag march) $(get-flag mcpu) $(get-flag mtune) ; do
- [ "${i}" = "native" ] && i="host" # bug #273421
- myconf="${myconf} --cpu=${i}"
- break
- done
-
- if use pic ; then
- myconf="${myconf} --enable-pic"
- # disable asm code if PIC is required
- # as the provided asm decidedly is not PIC for x86.
- use x86 && myconf="${myconf} --disable-asm"
- fi
-
- # cross compile support
- if tc-is-cross-compiler ; then
- myconf="${myconf} --enable-cross-compile --arch=$(tc-arch-kernel) --cross-prefix=${CHOST}-"
- case ${CHOST} in
- *freebsd*)
- myconf="${myconf} --target-os=freebsd"
- ;;
- mingw32*)
- myconf="${myconf} --target-os=mingw32"
- ;;
- *linux*)
- myconf="${myconf} --target-os=linux"
- ;;
- esac
- fi
-
- cd "${S}"
- ./configure \
- --prefix="${EPREFIX}/usr" \
- --libdir="${EPREFIX}/usr/$(get_libdir)" \
- --shlibdir="${EPREFIX}/usr/$(get_libdir)" \
- --enable-shared \
- --cc="$(tc-getCC)" \
- --ar="$(tc-getAR)" \
- --optflags="${CFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- $(use_enable static-libs static) \
- ${myconf} || die
-}