summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-13 11:50:34 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-13 12:12:29 -0400
commit84772ad0f55a494920ddb0e770b79ef2e8e6bf55 (patch)
treedb99673e058e2f6a5273c322d8647e9304c06898 /media-libs
parentmedia-gfx/simple-scan: Drop old versions (diff)
downloadgentoo-84772ad0f55a494920ddb0e770b79ef2e8e6bf55.tar.gz
gentoo-84772ad0f55a494920ddb0e770b79ef2e8e6bf55.tar.bz2
gentoo-84772ad0f55a494920ddb0e770b79ef2e8e6bf55.zip
media-libs/graphene: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/graphene/graphene-1.10.2.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/media-libs/graphene/graphene-1.10.2.ebuild b/media-libs/graphene/graphene-1.10.2.ebuild
deleted file mode 100644
index bb80f5eb2d54..000000000000
--- a/media-libs/graphene/graphene-1.10.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-inherit xdg-utils meson multilib-minimal python-any-r1
-
-DESCRIPTION="A thin layer of types for graphic libraries"
-HOMEPAGE="https://ebassi.github.io/graphene/"
-SRC_URI="https://github.com/ebassi/graphene/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86"
-IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 doc +introspection test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/glib-2.30.0:2[${MULTILIB_USEDEP}]
- introspection? ( dev-libs/gobject-introspection:= )
-"
-DEPEND="${RDEPEND}"
-# Python is only needed with USE=introspection or FEATURES=test, but not bothering with conditional python_setup, as meson uses it too anyway
-BDEPEND="
- ${PYTHON_DEPS}
- doc? ( dev-util/gtk-doc
- app-text/docbook-xml-dtd:4.3 )
- virtual/pkgconfig
-"
-
-multilib_src_configure() {
- # TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
- local emesonargs=(
- -Dgtk_doc=$(multilib_native_usex doc true false)
- -Dgobject_types=true
- -Dintrospection=$(multilib_native_usex introspection true false)
- -Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
- $(meson_use cpu_flags_x86_sse2 sse2)
- $(meson_use cpu_flags_arm_neon arm_neon)
- $(meson_use test tests)
- -Dinstalled_tests=false
- )
- meson_src_configure
-}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_test() {
- meson_src_test
-}
-
-multilib_src_install() {
- meson_src_install
-}