summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-08-24 12:57:41 -0700
committerMatt Turner <mattst88@gentoo.org>2021-08-24 13:01:28 -0700
commit9d05580c3f1ba502d81cd3513daf494680061526 (patch)
tree205ae5dd2ef49f94f8918c87ad4e3ebc99907cd8 /media-libs
parentdev-util/idea-community: Version bump, remove old. (diff)
downloadgentoo-9d05580c3f1ba502d81cd3513daf494680061526.tar.gz
gentoo-9d05580c3f1ba502d81cd3513daf494680061526.tar.bz2
gentoo-9d05580c3f1ba502d81cd3513daf494680061526.zip
media-libs/libglvnd: Version bump to 1.3.4
Closes: https://bugs.gentoo.org/717352 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libglvnd/Manifest1
-rw-r--r--media-libs/libglvnd/libglvnd-1.3.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/media-libs/libglvnd/Manifest b/media-libs/libglvnd/Manifest
index 8e3cd1ae9a9c..701bb5028ab2 100644
--- a/media-libs/libglvnd/Manifest
+++ b/media-libs/libglvnd/Manifest
@@ -1 +1,2 @@
DIST libglvnd-1.3.3.tar.bz2 715179 BLAKE2B 781550cbda489dca31596115c78edd1d4f1fe66062218c83ccf6cb34707501fce839b649c2b0aee3621c283397acca8fb40ad16c0388551ce7caa7fd79b7dbf5 SHA512 7da9e12c010a8f109cd24ca4c2ffc846dd7d23f82157e1e39b8ae69575fabcc9592c0b639b23d2112fe2026b679f1536f1b705a5c948fefea105418803e1b629
+DIST libglvnd-1.3.4.tar.bz2 715616 BLAKE2B 77866bcd80b80dc27accbe960d63f45b5052ad110590890ed4707db0c2d7efd6882755f7258fc007b3b11bed9cee02477103ed65003185f9d7d2f6e82bef7df8 SHA512 3132bf2a547d5b7ffe12c6f1574b62c666cce8708d0311dccdbdb82063e5b6efd6f889ff1829d550af903305cd7c5bd2f7c5e0253234b25e0ea98234769e7ccf
diff --git a/media-libs/libglvnd/libglvnd-1.3.4.ebuild b/media-libs/libglvnd/libglvnd-1.3.4.ebuild
new file mode 100644
index 000000000000..430500414962
--- /dev/null
+++ b/media-libs/libglvnd/libglvnd-1.3.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/glvnd/libglvnd.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+PYTHON_COMPAT=( python3_{7..9} )
+VIRTUALX_REQUIRED=manual
+
+inherit ${GIT_ECLASS} meson-multilib python-any-r1 virtualx
+
+DESCRIPTION="The GL Vendor-Neutral Dispatch library"
+HOMEPAGE="https://gitlab.freedesktop.org/glvnd/libglvnd"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ SRC_URI="https://gitlab.freedesktop.org/glvnd/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+ S=${WORKDIR}/${PN}-v${PV}
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test X"
+RESTRICT="!test? ( test )"
+
+BDEPEND="${PYTHON_DEPS}
+ test? ( X? ( ${VIRTUALX_DEPEND} ) )"
+RDEPEND="
+ !media-libs/mesa[-libglvnd(+)]
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+src_prepare() {
+ default
+ sed -i -e "/^PLATFORM_SYMBOLS/a '__gentoo_check_ldflags__'," \
+ bin/symbols-check.py || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature X x11)
+ $(meson_feature X glx)
+ )
+ use elibc_musl && emesonargs+=( -Dtls=disabled )
+
+ meson_src_configure
+}
+
+multilib_src_test() {
+ if use X; then
+ virtx meson_src_test
+ else
+ meson_src_test
+ fi
+}