summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-28 19:40:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-11 12:35:10 +0200
commita9aa237e23e632bdae14a58c3b0f4fdee162db71 (patch)
tree12f6ed97feda98b035620d3270b39c60875c4a2c /media-libs
parentmedia-libs/libcdaudio: EAPI7, improve ebuild (diff)
downloadgentoo-a9aa237e23e632bdae14a58c3b0f4fdee162db71.tar.gz
gentoo-a9aa237e23e632bdae14a58c3b0f4fdee162db71.tar.bz2
gentoo-a9aa237e23e632bdae14a58c3b0f4fdee162db71.zip
media-libs/libclalsadrv: EAPI7, improve ebuild
Closes: https://github.com/gentoo/gentoo/pull/9367
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libclalsadrv/libclalsadrv-2.0.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/libclalsadrv/libclalsadrv-2.0.0-r1.ebuild b/media-libs/libclalsadrv/libclalsadrv-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..0579ddc42586
--- /dev/null
+++ b/media-libs/libclalsadrv/libclalsadrv-2.0.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P=${P/lib}
+
+DESCRIPTION="ALSA driver C++ access library"
+HOMEPAGE="http://packages.debian.org/libclalsadrv"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P/lib}/libs"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_compile() {
+ tc-export CXX
+ emake
+}
+
+src_install() {
+ emake LIBDIR="$(get_libdir)" PREFIX="${D}/usr" install
+ dodoc ../AUTHORS
+}