summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2018-01-24 12:54:04 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2018-02-06 03:58:37 -0700
commitb5b476ac5ed17050bf29e4766f2414004f81e95e (patch)
tree7ca65a702554ff030bb29a0a5a08821a485a515e /media-libs
parentnet-proxy/sshuttle: use upstream python3 patch (diff)
downloadgentoo-b5b476ac5ed17050bf29e4766f2414004f81e95e.tar.gz
gentoo-b5b476ac5ed17050bf29e4766f2414004f81e95e.tar.bz2
gentoo-b5b476ac5ed17050bf29e4766f2414004f81e95e.zip
media-libs/gexiv2: Version bump to gexiv2-0.10.8
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gexiv2/Manifest1
-rw-r--r--media-libs/gexiv2/gexiv2-0.10.8.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/gexiv2/Manifest b/media-libs/gexiv2/Manifest
index e640dcd80dd4..18d52e04814a 100644
--- a/media-libs/gexiv2/Manifest
+++ b/media-libs/gexiv2/Manifest
@@ -1,3 +1,4 @@
DIST gexiv2-0.10.3.tar.xz 244816 BLAKE2B 79177a679c0d10c90a266c023930e27318f2e784e599b8f84a7356534045695e4ca44890b87eb0da4c16673e6e58c3ad77c80e404df2e76662f5a9250fc58e85 SHA512 a258a95e3e9dddc6636430d8a2bc222b6605e5d0d122ea1b951f97568cecd04b2d3cbc522625918faf3b5a3e670b01db81a45c2c5c5d65e6eb4b4f4a2ac69e8f
DIST gexiv2-0.10.5.tar.xz 591752 BLAKE2B 2fe5beaec7a6c2c9c55e8669c1cd8077cb5636f9b188b1ae64212582a23b514ece68108dbd3d4369417af6901579a28b69beb1a44013b51a3517f7fcf4f3e409 SHA512 350e9db388d0aa1c106f3e5bf8862206977d650be0223229c61c6a3ee20642890fbfd7681a215b9c85c10d0787a00a25bc05a639e19a5f39be27cb6d1bb0fc06
DIST gexiv2-0.10.6.tar.xz 629872 BLAKE2B 9a0f0b98eb1f19d4642cd0fb692b8ec539d3aa98f5c47f04317466877c404955d86c7fb4b2399fee30191555340fbc7701e19132d707f57d123cb16771507570 SHA512 4b15b33af9266a69babd902d379edefe7afd3d2eef11aa3c144f9ddf9c645b697bae16b8d89f50e9b3da884f1ba32f505e118c5fef5204f5630e3a9c6fee7fca
+DIST gexiv2-0.10.8.tar.xz 634696 BLAKE2B 182cda3bac5b3211e5ef8267628a86cc496c0242f25c5cd94ed9eab81c7460022373f3bb794c976fd0b9a10e49f9ca7109521ac6f99bbe7a4e0306a31db899da SHA512 4c25cf6884495151947a70e62a096f3279223673bece4d4ff02720b2820aaad9e80c8715e02bf46c3f5598f582fdf07b4b3ddabd017d53001245e3381a4cc286
diff --git a/media-libs/gexiv2/gexiv2-0.10.8.ebuild b/media-libs/gexiv2/gexiv2-0.10.8.ebuild
new file mode 100644
index 000000000000..1ace566e3332
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.10.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit autotools eutils multilib python-r1 toolchain-funcs versionator vala xdg-utils
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://wiki.gnome.org/Projects/gexiv2"
+SRC_URI="mirror://gnome/sources/${PN}/${MY_PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="introspection python static-libs test vala"
+
+REQUIRED_USE="
+ python? ( introspection ${PYTHON_REQUIRED_USE} )
+ test? ( python )
+ vala? ( introspection )
+"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.1:2
+ >=media-gfx/exiv2-0.21:0=
+ introspection? ( dev-libs/gobject-introspection:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ xdg_environment_reset
+ tc-export CXX
+ use vala && vala_src_prepare
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable vala)
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIB="$(get_libdir)" install
+ dodoc AUTHORS NEWS README THANKS
+
+ if use python ; then
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+ fi
+
+ use static-libs || prune_libtool_files --modules
+}