summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-02-20 12:23:50 +0100
committerJeroen Roovers <jer@gentoo.org>2016-02-20 12:24:05 +0100
commitb8e66d798f0705146b1e1602a1adf2f4c2a7247d (patch)
tree25870235895cc77b13d9f0d60be006491e861933 /media-libs
parentdev-java/jacoco: Stable for amd64. Retroactively mark stable for the remainin... (diff)
downloadgentoo-b8e66d798f0705146b1e1602a1adf2f4c2a7247d.tar.gz
gentoo-b8e66d798f0705146b1e1602a1adf2f4c2a7247d.tar.bz2
gentoo-b8e66d798f0705146b1e1602a1adf2f4c2a7247d.zip
media-libs/libfpx: Version bump (bug #395367)
Also, store the upstream revision in PV Package-Manager: portage-2.2.27
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libfpx/Manifest1
-rw-r--r--media-libs/libfpx/libfpx-1.3.1_p6.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-libs/libfpx/Manifest b/media-libs/libfpx/Manifest
index 2ea3eeedb56d..2d2291125a90 100644
--- a/media-libs/libfpx/Manifest
+++ b/media-libs/libfpx/Manifest
@@ -1 +1,2 @@
DIST libfpx-1.3.0-1.tar.bz2 2285921 SHA256 0cc240e9458d099c0a50db9c771b3e5b109164472c08f40f31e1190716af48b6 SHA512 f045edb01046ec3d2fee8eeee8a861ebcb63b3b9094a93d4bda28e8009117bdbb7e843bdf4aa8d0502482acec7c2ea51df53b88ab2bf6a61c37aed8653579e67 WHIRLPOOL 16dc643d2602d44fe626fd2c1d35e743dbcfb825fc53e8a20a95145275d71d770fafd75e59b4b74fa5b42ef52f9339474fe877455c04a8f668c47d700d580fb3
+DIST libfpx-1.3.1-6.tar.bz2 2358328 SHA256 84e663bb23619e19195777a7c5d348046756f28cffda3d0ea2160ed0b55a698a SHA512 d33bc59f091100f4e0f7db396ba2f3a93951b348f8b175070fa23186f7ce488e71b7be43a45ebd9a3af21affe5342f63955df8549ff15582f8b29e67601531fb WHIRLPOOL d107a1ee69d018699567761603ce21ba6f6b80e25d5e3e53f6a76ef262602d0d344127c6a0c7f372c2da60a3b293882184513d4a77e674c32b384d5c8798a4bf
diff --git a/media-libs/libfpx/libfpx-1.3.1_p6.ebuild b/media-libs/libfpx/libfpx-1.3.1_p6.ebuild
new file mode 100644
index 000000000000..ef50b4e554ec
--- /dev/null
+++ b/media-libs/libfpx/libfpx-1.3.1_p6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic libtool
+
+DESCRIPTION="A library for manipulating FlashPIX images"
+HOMEPAGE="http://www.i3a.org/"
+SRC_URI="mirror://imagemagick/delegates/${P/_p/-}.tar.bz2"
+
+LICENSE="Flashpix"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="static-libs"
+
+S=${WORKDIR}/${P/_p/-}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.0.13-export-symbols.patch
+
+ eapply_user
+
+ # we're not windows, even though we don't define __unix by default
+ [[ ${CHOST} == *-darwin* ]] && append-flags -D__unix
+
+ elibtoolize
+}
+
+src_configure() {
+ append-ldflags -Wl,--no-undefined
+ econf \
+ $(use_enable static-libs static) \
+ LIBS="-lstdc++ -lm"
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog doc/*.txt
+
+ insinto /usr/share/doc/${PF}/pdf
+ doins doc/*.pdf
+}