summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-04-29 19:46:46 +0200
committerSebastian Pipping <sping@gentoo.org>2018-04-29 19:50:44 +0200
commitc65f3122b5e0996bdb9c143d3d6393d3dddb9ffa (patch)
treef30f642139f057ae060a74e0c863e1c732fe317f /media-libs
parentnet-misc/networkmanager: bump to 1.10.6 (diff)
downloadgentoo-c65f3122b5e0996bdb9c143d3d6393d3dddb9ffa.tar.gz
gentoo-c65f3122b5e0996bdb9c143d3d6393d3dddb9ffa.tar.bz2
gentoo-c65f3122b5e0996bdb9c143d3d6393d3dddb9ffa.zip
media-libs/gegl: 0.4.0
Bug: https://bugs.gentoo.org/654240 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gegl/Manifest1
-rw-r--r--media-libs/gegl/gegl-0.4.0.ebuild179
-rw-r--r--media-libs/gegl/gegl-9999.ebuild2
3 files changed, 181 insertions, 1 deletions
diff --git a/media-libs/gegl/Manifest b/media-libs/gegl/Manifest
index c1a611b21c51..928eec7d3813 100644
--- a/media-libs/gegl/Manifest
+++ b/media-libs/gegl/Manifest
@@ -7,3 +7,4 @@ DIST gegl-0.3.28.tar.bz2 6530569 BLAKE2B ac802c312a0fa44bec8ec4c41454fc9aabebdb1
DIST gegl-0.3.30.tar.bz2 6675564 BLAKE2B 177db85f8225f9cbb04774d270e0d71db598099be814157ad46ca7a9ceee2d60efde2e02ec2f81ef5c8bcc14e06c5d1d03718f6cc0005c576aa47a1f233a07c2 SHA512 4506eed9980e2a455b43b643d50b3a89d12b605ee4584fc7dd5c63be60acae64eda88f580ecb82891a4b0d69af10730a0d1525de7cc468afccdf2cf78f85b2eb
DIST gegl-0.3.34.tar.bz2 6707964 BLAKE2B 4424a2c218067bd0a77d79c2334528da393350db3062019f3889b8cdb8d222f6e436ccfc845b61fdf425a1634698a7a6963702a29bb1666f515b1395c50dc99f SHA512 a7a394dcce4137d5224163ca324f1585e64d1cc797e77d452ba444afe2bff39aa2e2d5d040d07b394697b75162bc310bc51490a5af80240b26aac14b6e7abe02
DIST gegl-0.3.8.tar.bz2 5876259 BLAKE2B 24199148ffbef6454ea460d126c29f1cc8581e5430bc3e341a8ab48fff701a0d63c4cf8864d04219455feaeb7e03808e8de06cc8ae0a500eb4154f2ec9ba25fe SHA512 13207e7ab4723be1e31bdba5e30e5725e93c1adc61bad1413502128730391dbe7eb35419d243c8d0a1d8794341a58188790adacbb10d2a8e68db861c18d21bfb
+DIST gegl-0.4.0.tar.bz2 6762190 BLAKE2B c138ee79806178f60eab2fae492fcf441dc49b54364abcf023f6ade0cb08d216200ae14a289af8b6da2f0eec97dc81d376469245d0aa6d6cabf269d42c0a83c0 SHA512 4e319e861f6a27f52d0d4920942abe3734e6015eaa76491ab55179d8c677ccf8eb7f4296ef43f55a5e77ae9e99bb2ba6f5bd20aa08f194e9d42a1159fae20c6e
diff --git a/media-libs/gegl/gegl-0.4.0.ebuild b/media-libs/gegl/gegl-0.4.0.ebuild
new file mode 100644
index 000000000000..a247b71cd607
--- /dev/null
+++ b/media-libs/gegl/gegl-0.4.0.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+# vala and introspection support is broken, bug #468208
+VALA_USE_DEPEND=vapigen
+
+inherit versionator gnome2-utils eutils autotools python-any-r1 vala
+
+if [[ ${PV} == *9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://git.gnome.org/gegl"
+ SRC_URI=""
+else
+ SRC_URI="http://download.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A graph based image processing framework"
+HOMEPAGE="http://www.gegl.org/"
+
+LICENSE="|| ( GPL-3 LGPL-3 )"
+SLOT="0.4"
+
+IUSE="cairo cpu_flags_x86_mmx cpu_flags_x86_sse debug ffmpeg +introspection jpeg2k lcms lensfun openexr raw sdl svg test tiff umfpack vala v4l webp"
+REQUIRED_USE="
+ svg? ( cairo )
+ vala? ( introspection )
+"
+
+# NOTE: Even current libav 11.4 does not have AV_CODEC_CAP_VARIABLE_FRAME_SIZE
+# so there is no chance to support libav right now (Gentoo bug #567638)
+# If it returns, please check prior GEGL ebuilds for how libav was integrated. Thanks!
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ dev-libs/json-glib
+ >=media-libs/babl-0.1.46
+ sys-libs/zlib
+ >=x11-libs/gdk-pixbuf-2.32:2
+ x11-libs/pango
+
+ cairo? ( >=x11-libs/cairo-1.12.2 )
+ ffmpeg? (
+ >=media-video/ffmpeg-2.8:0=
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ virtual/jpeg:0=
+ jpeg2k? ( >=media-libs/jasper-1.900.1:= )
+ lcms? ( >=media-libs/lcms-2.8:2 )
+ lensfun? ( >=media-libs/lensfun-0.2.5 )
+ openexr? ( >=media-libs/openexr-1.6.1:= )
+ >=media-libs/libpng-1.6.0:0=
+ raw? ( >=media-libs/libraw-0.15.4:0= )
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ svg? ( >=gnome-base/librsvg-2.40.6:2 )
+ tiff? ( >=media-libs/tiff-4:0 )
+ umfpack? ( sci-libs/umfpack )
+ v4l? ( >=media-libs/libv4l-1.0.1 )
+ webp? ( >=media-libs/libwebp-0.5.0:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1
+ >=sys-devel/gettext-0.19.8
+ dev-lang/perl
+ virtual/pkgconfig
+ >=sys-devel/libtool-2.2
+ test? ( introspection? (
+ $(python_gen_any_dep '>=dev-python/pygobject-3.2[${PYTHON_USEDEP}]') ) )
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use test && use introspection && python-any-r1_pkg_setup
+}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
+src_prepare() {
+ default
+
+ # FIXME: the following should be proper patch sent to upstream
+ # fix OSX loadable module filename extension
+ sed -i -e 's/\.dylib/.bundle/' configure.ac || die
+ # don't require Apple's OpenCL on versions of OSX that don't have it
+ if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -le 9 ]] ; then
+ sed -i -e 's/#ifdef __APPLE__/#if 0/' gegl/opencl/* || die
+ fi
+
+ # commit 7c78497b : tests that use gegl.png are broken on non-amd64
+ sed -e '/clones.xml/d' \
+ -e '/composite-transform.xml/d' \
+ -i tests/compositions/Makefile.am || die
+
+ eautoreconf
+
+ gnome2_environment_reset
+
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ # never enable altering of CFLAGS via profile option
+ # libspiro: not in portage main tree
+ # disable documentation as the generating is bit automagic
+ # if anyone wants to work on it just create bug with patch
+
+ # Also please note that:
+ #
+ # - Some auto-detections are not patched away since the docs are
+ # not built (--disable-docs, lack of --enable-gtk-doc) and these
+ # tools affect re-generation of docs, only
+ # (e.g. ruby, asciidoc, dot (of graphviz), enscript)
+ #
+ # - Parameter --with-exiv2 compiles a noinst-app only, no use
+ #
+ # - Parameter --disable-workshop disables any use of Lua, effectivly
+ #
+ # - v4l support does not work with our media-libs/libv4l-0.8.9,
+ # upstream bug at https://bugzilla.gnome.org/show_bug.cgi?id=654675
+ #
+ # - There are two checks for dot, one controllable by --with(out)-graphviz
+ # which toggles HAVE_GRAPHVIZ that is not used anywhere. Yes.
+ #
+ # - mrg is not in tree and gexiv2 support only has effect when mrg support
+ # is enabled
+ #
+ # So that's why USE="exif graphviz lua v4l" got resolved. More at:
+ # https://bugs.gentoo.org/show_bug.cgi?id=451136
+ #
+ econf \
+ --disable-docs \
+ --disable-profile \
+ --disable-silent-rules \
+ --disable-workshop \
+ --program-suffix=-${SLOT} \
+ --with-gdk-pixbuf \
+ --with-pango \
+ --without-libspiro \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable debug) \
+ $(use_with cairo) \
+ $(use_with cairo pangocairo) \
+ --without-exiv2 \
+ $(use_with ffmpeg libavformat) \
+ --without-gexiv2 \
+ --without-graphviz \
+ $(use_with jpeg2k jasper) \
+ $(use_with lcms) \
+ $(use_with lensfun) \
+ --without-lua \
+ --without-mrg \
+ $(use_with openexr) \
+ $(use_with raw libraw) \
+ $(use_with sdl) \
+ $(use_with svg librsvg) \
+ $(use_with tiff libtiff) \
+ $(use_with umfpack) \
+ $(use_with v4l libv4l) \
+ $(use_with v4l libv4l2) \
+ $(use_enable introspection) \
+ $(use_with vala) \
+ $(use_with webp)
+}
+
+src_compile() {
+ default
+
+ [[ ${PV} == *9999* ]] && emake ./ChangeLog # "./" prevents "Circular ChangeLog <- ChangeLog dependency dropped."
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/gegl/gegl-9999.ebuild b/media-libs/gegl/gegl-9999.ebuild
index 927662caeff6..5fe47759f341 100644
--- a/media-libs/gegl/gegl-9999.ebuild
+++ b/media-libs/gegl/gegl-9999.ebuild
@@ -22,7 +22,7 @@ DESCRIPTION="A graph based image processing framework"
HOMEPAGE="http://www.gegl.org/"
LICENSE="|| ( GPL-3 LGPL-3 )"
-SLOT="0.3"
+SLOT="0.4"
IUSE="cairo cpu_flags_x86_mmx cpu_flags_x86_sse debug ffmpeg +introspection jpeg2k lcms lensfun libav openexr raw sdl svg test tiff umfpack vala v4l webp"
REQUIRED_USE="