summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro@users.noreply.github.com>2023-04-15 17:05:24 -0400
committerSam James <sam@gentoo.org>2023-04-26 05:02:58 +0100
commitd33429e60f1fe2ec0d99cfc1e093b80854473abe (patch)
tree428269d0c5280af8848febf52110ff3e33f0143b /media-libs
parentdev-db/mydumper: add 0.14.4.1 (diff)
downloadgentoo-d33429e60f1fe2ec0d99cfc1e093b80854473abe.tar.gz
gentoo-d33429e60f1fe2ec0d99cfc1e093b80854473abe.tar.bz2
gentoo-d33429e60f1fe2ec0d99cfc1e093b80854473abe.zip
media-libs/game-music-emu: wire up tests
Bug: https://bugs.gentoo.org/896118 Signed-off-by: Matoro Mahri <matoro@users.noreply.github.com> Closes: https://github.com/gentoo/gentoo/pull/30610 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/game-music-emu/game-music-emu-0.6.3.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/media-libs/game-music-emu/game-music-emu-0.6.3.ebuild b/media-libs/game-music-emu/game-music-emu-0.6.3.ebuild
index b2cdad293133..cffc088aaeea 100644
--- a/media-libs/game-music-emu/game-music-emu-0.6.3.ebuild
+++ b/media-libs/game-music-emu/game-music-emu-0.6.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-multilib
+inherit cmake-multilib multibuild
DESCRIPTION="Video game music file emulators"
HOMEPAGE="https://bitbucket.org/mpyne/game-music-emu/wiki/Home"
@@ -12,7 +12,10 @@ SRC_URI="https://bitbucket.org/mpyne/game-music-emu/downloads/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv x86"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( sys-process/parallel )"
DOCS=( changes.txt design.txt gme.txt readme.txt )
@@ -22,3 +25,7 @@ src_configure() {
)
cmake-multilib_src_configure
}
+
+multilib_src_test() {
+ emake -C "${S}/test" test LIBGME_NEW_PATH="${BUILD_DIR}/gme/libgme.so" CXXFLAGS="${CXXFLAGS}"
+}