summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-03-10 13:06:33 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-03-10 13:45:08 +0100
commitd57cbea1bb77dd707fed0e1e2167782931d0dc53 (patch)
tree8d8a6ce935751e255450965739a0a7b49b09b7ce /media-libs
parentdev-qt/qtvirtualkeyboard: Drop 5.15.2-r11 (diff)
downloadgentoo-d57cbea1bb77dd707fed0e1e2167782931d0dc53.tar.gz
gentoo-d57cbea1bb77dd707fed0e1e2167782931d0dc53.tar.bz2
gentoo-d57cbea1bb77dd707fed0e1e2167782931d0dc53.zip
media-libs/x264: bump to latest version
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/x264/Manifest1
-rw-r--r--media-libs/x264/x264-0.0.20220222.ebuild66
-rw-r--r--media-libs/x264/x264-9999.ebuild10
3 files changed, 72 insertions, 5 deletions
diff --git a/media-libs/x264/Manifest b/media-libs/x264/Manifest
index c1e5f3cbddf9..1cedc164b43d 100644
--- a/media-libs/x264/Manifest
+++ b/media-libs/x264/Manifest
@@ -1 +1,2 @@
+DIST x264-0.0.20220222.tar.bz2 777236 BLAKE2B 45e57c48b4b889f5c7b4ce87d1442d26d907aac47fb7c586b34239317a8b74bb93eac3058eed766728fbca6370656d9a6f070e8992643984a89560e28edf206d SHA512 1cf864059f83731ac47008c1af1d9ac06d06283439cf883a020f8a76e0c7efc3b525791d11efe8784d0e39ded68dd03794f0502fa64cc07df2f2de064a55e1d9
DIST x264-snapshot-20190903-2245.tar.bz2 774515 BLAKE2B 0b19fc1d3cedea32bfac9c5247bce7b3c04dead35458d61f3b5c0694040dc852b0110b620faf4118ed265a5605aafce3c49d468d38fb91e4c515b2860c486920 SHA512 c357c9025ffdf653c974eb7ccc2e9a4de86c02881372a6a8270ae59ce948c284da48a2aba37763bd29359d2a6dfc76ea56a52fed6082f8483912c8f948488a2d
diff --git a/media-libs/x264/x264-0.0.20220222.ebuild b/media-libs/x264/x264-0.0.20220222.ebuild
new file mode 100644
index 000000000000..b7548e05ce9b
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20220222.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal toolchain-funcs
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="https://www.videolan.org/developers/x264.html"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://code.videolan.org/videolan/x264.git"
+else
+ # Download https://code.videolan.org/videolan/x264/-/archive/master/x264-master.tar.bz2
+ SRC_URI="https://dev.gentoo.org/~aballier/distfiles/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+ S="${WORKDIR}/${PN}-master"
+fi
+
+SLOT="0/164" # SONAME
+
+LICENSE="GPL-2"
+IUSE="cpu_flags_ppc_altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
+
+ASM_DEP=">=dev-lang/nasm-2.13"
+DEPEND="abi_x86_32? ( ${ASM_DEP} )
+ abi_x86_64? ( ${ASM_DEP} )
+ opencl? ( dev-lang/perl )"
+RDEPEND="opencl? ( >=virtual/opencl-0-r3[${MULTILIB_USEDEP}] )"
+
+DOCS=( AUTHORS doc/{ratecontrol,regression_test,standards,threads,vui}.txt )
+
+multilib_src_configure() {
+ tc-export CC
+
+ if [[ ${ABI} == x86 || ${ABI} == amd64 ]]; then
+ export AS="nasm"
+ else
+ export AS="${CC}"
+ fi
+
+ local asm_conf=""
+
+ if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !cpu_flags_ppc_altivec ; }; then
+ asm_conf=" --disable-asm"
+ fi
+
+ "${S}/configure" \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --disable-cli \
+ --disable-avs \
+ --disable-lavf \
+ --disable-swscale \
+ --disable-ffms \
+ --disable-gpac \
+ --enable-pic \
+ --enable-shared \
+ --host="${CHOST}" \
+ --cross-prefix="${CHOST}-" \
+ $(usex interlaced "" "--disable-interlaced") \
+ $(usex opencl "" "--disable-opencl") \
+ $(usex static-libs "--enable-static" "") \
+ $(usex threads "" "--disable-thread") \
+ ${asm_conf} || die
+}
diff --git a/media-libs/x264/x264-9999.ebuild b/media-libs/x264/x264-9999.ebuild
index b2963fe3f360..b7548e05ce9b 100644
--- a/media-libs/x264/x264-9999.ebuild
+++ b/media-libs/x264/x264-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,13 +11,13 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://code.videolan.org/videolan/x264.git"
else
- MY_P="x264-snapshot-$(ver_cut 3)-2245"
- SRC_URI="https://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+ # Download https://code.videolan.org/videolan/x264/-/archive/master/x264-master.tar.bz2
+ SRC_URI="https://dev.gentoo.org/~aballier/distfiles/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
- S="${WORKDIR}/${MY_P}"
+ S="${WORKDIR}/${PN}-master"
fi
-SLOT="0/161" # SONAME
+SLOT="0/164" # SONAME
LICENSE="GPL-2"
IUSE="cpu_flags_ppc_altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"