summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOvidiu-Dan Bogat <4z0r@ovidiu.at>2020-02-27 12:40:45 +0100
committerAkinori Hattori <hattya@gentoo.org>2020-03-01 11:01:06 +0900
commite37bb40b1098f42fafccb6ebd8fcd4534290b942 (patch)
treea54058fb7145c129ef3d3af8ca6e4071ce5f3f52 /media-libs
parentapp-misc/ytree: version bump 2.01 (diff)
downloadgentoo-e37bb40b1098f42fafccb6ebd8fcd4534290b942.tar.gz
gentoo-e37bb40b1098f42fafccb6ebd8fcd4534290b942.tar.bz2
gentoo-e37bb40b1098f42fafccb6ebd8fcd4534290b942.zip
media-libs/libsixel: version bump to 1.8.6
Reported-by: D'juan McDonald <flopwiki@gmail.com> Bug: https://bugs.gentoo.org/674620 Closes: https://github.com/gentoo/gentoo/pull/14790 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Ovidiu-Dan Bogat <4z0r@ovidiu.at> Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsixel/Manifest1
-rw-r--r--media-libs/libsixel/libsixel-1.8.6.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/media-libs/libsixel/Manifest b/media-libs/libsixel/Manifest
index 39b2184aa9e3..5d7be2386fb2 100644
--- a/media-libs/libsixel/Manifest
+++ b/media-libs/libsixel/Manifest
@@ -1,2 +1,3 @@
DIST libsixel-1.8.1.tar.gz 4777791 BLAKE2B de96029990acc00e0c5fa81e6f892153000a93841b8e152ecc2ae3db0e7ca1dbe5063fdbf69f79f23c82095b253206c7bea0f638ed7536ebcf3d0d23a1137965 SHA512 af38b47aac443bfb443aa7b12041ecc1496722afbc861ad8572e90c34c7c1ed4ee04241d5d5f3abb7d8be945fac2a1f718494c4fbd023a6a7b9f6d912f90554c
DIST libsixel-1.8.2.tar.gz 4778776 BLAKE2B a43ff76e271b27337fa4144bd89170f33bfae535696f5107cc77b3adef370e89d9da950746621ec7002b201f68dba873f99463d8b2183c319b62f2574f0562a3 SHA512 f0287b7b7a190f0f964e27fc65aa816a78c09de5e50045a25eb05f9b430c74f779a7d5eb591b3430a82a06621d53719bf115bcdd0b99acc9afe3cb9ab6fde271
+DIST libsixel-1.8.6.tar.gz 4791628 BLAKE2B 5fa197d0d759eecd4040c4c1101e6d85fb9af7405ccdff75be571b3ac6b2b0aab6415bc3fdbb37157795f89190fcc1d0fea1bdf705e83a34762e2b05f5588c69 SHA512 460a5d46bada705b4a7ec2e250e2bde7f4b8ba155281fa5a102d1121f79c1c79145f042cd1f4bf93a2fc29e784e89afd539e963470663fc659d4fe72ea49fdaf
diff --git a/media-libs/libsixel/libsixel-1.8.6.ebuild b/media-libs/libsixel/libsixel-1.8.6.ebuild
new file mode 100644
index 000000000000..f938c80c4d36
--- /dev/null
+++ b/media-libs/libsixel/libsixel-1.8.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit bash-completion-r1
+
+DESCRIPTION="A lightweight, fast implementation of DEC SIXEL graphics codec"
+HOMEPAGE="https://github.com/saitoha/libsixel"
+SRC_URI="https://github.com/saitoha/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="curl gd gtk jpeg png static-libs"
+
+RDEPEND="curl? ( net-misc/curl )
+ gd? ( media-libs/gd )
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with curl libcurl) \
+ $(use_with gd) \
+ $(use_with gtk gdk-pixbuf2) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_enable static-libs static) \
+ --with-bashcompletiondir=$(get_bashcompdir) \
+ --disable-python
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete || die
+
+ cd images
+ docompress -x /usr/share/doc/${PF}/images
+ docinto images
+ dodoc egret.jpg map{8,16}.png snake.jpg vimperator3.png
+}