summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Flogeras <dflogeras2@gmail.com>2021-12-02 09:23:44 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-12-04 10:15:09 +0200
commite8075e15ff107f15538ab364b4e3ec4ebfa862b8 (patch)
treed6e5b8feb98f7175d447713215dc81b1f731ad60 /media-libs
parentsys-boot/woeusb: drop 5.2.2 (diff)
downloadgentoo-e8075e15ff107f15538ab364b4e3ec4ebfa862b8.tar.gz
gentoo-e8075e15ff107f15538ab364b4e3ec4ebfa862b8.tar.bz2
gentoo-e8075e15ff107f15538ab364b4e3ec4ebfa862b8.zip
media-libs/kimageannotator: bump to 0.5.3
Bug: https://bugs.gentoo.org/828017 CLoses: https://bugs.gentoo.org/828017 Closes: https://github.com/gentoo/gentoo/pull/23149 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: David Flogeras <dflogeras2@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/kimageannotator/Manifest1
-rw-r--r--media-libs/kimageannotator/kimageannotator-0.5.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/kimageannotator/Manifest b/media-libs/kimageannotator/Manifest
index e0be57639db0..8239fd2d1eb5 100644
--- a/media-libs/kimageannotator/Manifest
+++ b/media-libs/kimageannotator/Manifest
@@ -1 +1,2 @@
DIST kImageAnnotator-0.5.2.tar.gz 219008 BLAKE2B 6d2d53a55b013b8bb87291ffcb13126437291145a4d869c9e4b031711b8592ef465eb2b24b6473c09f9d02067d2404da15a4170a2f4e288cb1475d3c5d7d00be SHA512 42785f92954bf8fe28f5114d8ba7da9a1a22e79d1c0356642e34754218e580b147670a119d94e3b6b704deb1230a0d0f4d998541d5532783e4d569c66789af99
+DIST kImageAnnotator-0.5.3.tar.gz 219782 BLAKE2B 30f532a563761a665da1f926629ebd66888f820b305c98f2b0afc316d8a94010196e68221a4ffd4871ffbae19582eee685af56c763f873b38a7ac5219f4a3b3d SHA512 a858e0f8694f3f989c36db586e6e3a302ad2aa9bf32b26afa170c165327fa33b6f3053682420c788f701abdea4daa35158058edddf52af1566364976b2d2f9f7
diff --git a/media-libs/kimageannotator/kimageannotator-0.5.3.ebuild b/media-libs/kimageannotator/kimageannotator-0.5.3.ebuild
new file mode 100644
index 000000000000..1fc3ed36ab23
--- /dev/null
+++ b/media-libs/kimageannotator/kimageannotator-0.5.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VIRTUALX_REQUIRED="test"
+inherit cmake virtualx
+
+MY_PN=kImageAnnotator
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for annotating images"
+HOMEPAGE="https://github.com/ksnip/kImageAnnotator"
+SRC_URI="https://github.com/ksnip/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5[png]
+ >=media-libs/kcolorpicker-0.1.6
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test
+}