summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2017-11-27 21:46:20 +0000
committerDenis Dupeyron <calchan@gentoo.org>2017-11-27 21:46:47 +0000
commitea34238048e3751b07f841935a5b4135965f745f (patch)
tree097eddd3a6e2f02cc5f0308102044068a6da44c8 /media-libs
parentdev-java/nanoxml: make patches EAPI 6 compliant. (diff)
downloadgentoo-ea34238048e3751b07f841935a5b4135965f745f.tar.gz
gentoo-ea34238048e3751b07f841935a5b4135965f745f.tar.bz2
gentoo-ea34238048e3751b07f841935a5b4135965f745f.zip
media-libs/libmpris2client: migrate to EAPI6
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libmpris2client/libmpris2client-0.1.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/libmpris2client/libmpris2client-0.1.0-r1.ebuild b/media-libs/libmpris2client/libmpris2client-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..0a29d009a666
--- /dev/null
+++ b/media-libs/libmpris2client/libmpris2client-0.1.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils
+
+DESCRIPTION="A library to control MPRIS2 compatible players"
+HOMEPAGE="https://github.com/matiasdelellis/libmpris2client"
+SRC_URI="https://github.com/matiasdelellis/${PN}/releases/download/V${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README TODO )
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}