summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-22 14:19:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-22 16:24:34 +0200
commitf5081e2efceec7b034d0519f0d60c3205bd86701 (patch)
tree482741ab6a7c0adaf4065de51ccd27876f2acca0 /media-libs
parentdev-ml/lwt: keyword ~arm64 (diff)
downloadgentoo-f5081e2efceec7b034d0519f0d60c3205bd86701.tar.gz
gentoo-f5081e2efceec7b034d0519f0d60c3205bd86701.tar.bz2
gentoo-f5081e2efceec7b034d0519f0d60c3205bd86701.zip
media-libs/zvbi: Fix building tests with gcc7.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/zvbi/files/tests-gcc7.patch22
-rw-r--r--media-libs/zvbi/zvbi-0.2.35-r1.ebuild1
2 files changed, 23 insertions, 0 deletions
diff --git a/media-libs/zvbi/files/tests-gcc7.patch b/media-libs/zvbi/files/tests-gcc7.patch
new file mode 100644
index 000000000000..181285cfbd46
--- /dev/null
+++ b/media-libs/zvbi/files/tests-gcc7.patch
@@ -0,0 +1,22 @@
+Index: zvbi-0.2.35/test/test-dvb_mux.cc
+===================================================================
+--- zvbi-0.2.35.orig/test/test-dvb_mux.cc
++++ zvbi-0.2.35/test/test-dvb_mux.cc
+@@ -137,7 +137,7 @@ is_good_service (vbi_service_set servi
+ static const vbi_service_set
+ all_services [] = {
+ 0,
+- -1,
++ (vbi_service_set)-1,
+ VBI_SLICED_2xCAPTION_525,
+ VBI_SLICED_CAPTION_525,
+ VBI_SLICED_CAPTION_525_F1,
+@@ -3237,7 +3237,7 @@ static void
+ test_dvb_mux_cor_pts (void)
+ {
+ static const int64_t ptss [] = {
+- 0x8000000000000000ll, -1, 0, 0x7FFFFFFFFFFFFFFFll,
++ (int64_t)0x8000000000000000ll, -1, 0, 0x7FFFFFFFFFFFFFFFll,
+ };
+ DVBPESMuxTest mx;
+ unsigned int i;
diff --git a/media-libs/zvbi/zvbi-0.2.35-r1.ebuild b/media-libs/zvbi/zvbi-0.2.35-r1.ebuild
index 1ebe916ea7c3..02b94b7885bb 100644
--- a/media-libs/zvbi/zvbi-0.2.35-r1.ebuild
+++ b/media-libs/zvbi/zvbi-0.2.35-r1.ebuild
@@ -24,6 +24,7 @@ DEPEND="${RDEPEND}
X? ( x11-libs/libXt )"
src_prepare() {
+ epatch "${FILESDIR}/tests-gcc7.patch"
elibtoolize
}