summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-22 17:31:42 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-22 23:57:27 +0300
commitf5ddd3f21315dec8f0a0bf32af26867d074d7639 (patch)
tree498530aedd432db10c5a48ba6928f60c7df64efd /media-libs
parentkde-apps/yakuake: Fix fullscreen mode regression (diff)
downloadgentoo-f5ddd3f21315dec8f0a0bf32af26867d074d7639.tar.gz
gentoo-f5ddd3f21315dec8f0a0bf32af26867d074d7639.tar.bz2
gentoo-f5ddd3f21315dec8f0a0bf32af26867d074d7639.zip
media-libs/cogl: bump to 1.22.8
Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/cogl/Manifest1
-rw-r--r--media-libs/cogl/cogl-1.22.8.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/media-libs/cogl/Manifest b/media-libs/cogl/Manifest
index fb3c9f7a416f..329c6a7a693d 100644
--- a/media-libs/cogl/Manifest
+++ b/media-libs/cogl/Manifest
@@ -1 +1,2 @@
DIST cogl-1.22.6.tar.xz 1744240 BLAKE2B d3483c972705ec72d2ccbd06106bdd37ea23a7940c7d5f5d8c45da43a8e5ed7bc2fb5f07838b5a0cfe9b54d3681120008c03945ee8bac39042a9c263e84d3549 SHA512 b3475fa4fff3b6725f643b0d17d2de242fce1503cd83bd18031d98495501917bf5173152fb1aba7f2614fcf6553029fbb6f26bda5a497f5f12e2849ed301a483
+DIST cogl-1.22.8.tar.xz 1742632 BLAKE2B c6230a2223928c5d4e5d87fa6b039c96000fac546e3e57e04e528b571500d350013a4b6e0a2ab6b2133672fec992fff6f9486ab8c83a01cf9790bc94266c75d4 SHA512 702d5b1b22dc34bffaa82c9c57021caf036ee3a13fa7ca24a90cca1ebc0f8b7a86070cc1fe5125757132b02774fa874bb55675c96d1ccbc233fac0e6132da65f
diff --git a/media-libs/cogl/cogl-1.22.8.ebuild b/media-libs/cogl/cogl-1.22.8.ebuild
new file mode 100644
index 000000000000..0582d681b12b
--- /dev/null
+++ b/media-libs/cogl/cogl-1.22.8.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 multilib
+
+DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
+HOMEPAGE="https://www.cogl3d.org/"
+
+LICENSE="MIT BSD"
+SLOT="1.0/20" # subslot = .so version
+
+# doc and profile disable for now due to bugs #484750 and #483332
+IUSE="debug examples gles2 gstreamer +introspection +kms +opengl +pango wayland" # doc profile
+REQUIRED_USE="
+ wayland? ( gles2 )
+ || ( gles2 opengl )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
+ x11-libs/cairo:=
+ >=x11-libs/gdk-pixbuf-2:2
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXrandr-1.2
+ virtual/opengl
+ gles2? ( media-libs/mesa[gles2] )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0 )
+ introspection? ( >=dev-libs/gobject-introspection-1.34.2:= )
+ kms? (
+ media-libs/mesa[egl,gbm]
+ x11-libs/libdrm:= )
+ pango? ( >=x11-libs/pango-1.20.0[introspection?] )
+ wayland? (
+ >=dev-libs/wayland-1.1.90
+ media-libs/mesa[egl,wayland] )
+"
+# before clutter-1.7, cogl was part of clutter
+RDEPEND="${COMMON_DEPEND}
+ !<media-libs/clutter-1.7
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19
+ virtual/pkgconfig
+"
+
+# Need classic mesa swrast for tests, llvmpipe causes a test failure
+# For some reason GL3 conformance test all fails again...
+RESTRICT="test"
+
+src_prepare() {
+ # Do not build examples
+ sed -e "s/^\(SUBDIRS +=.*\)examples\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+
+ #if ! use test ; then
+ # For some reason the configure switch will not completely disable
+ # tests being built
+ sed -e "s/^\(SUBDIRS =.*\)test-fixtures\(.*\)$/\1\2/" \
+ -e "s/^\(SUBDIRS +=.*\)tests\(.*\)$/\1\2/" \
+ -e "s/^\(.*am__append.* \)tests\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+ #fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # TODO: think about quartz, sdl
+ # Prefer gl over gles2 if both are selected
+ # Profiling needs uprof, which is not available in portage yet, bug #484750
+ # FIXME: Doesn't provide prebuilt docs, but they can neither be rebuilt, bug #483332
+ gnome2_src_configure \
+ --disable-examples-install \
+ --disable-maintainer-flags \
+ --enable-cairo \
+ --enable-deprecated \
+ --enable-gdk-pixbuf \
+ --enable-glib \
+ $(use_enable debug) \
+ $(use_enable opengl glx) \
+ $(use_enable opengl gl) \
+ $(use_enable gles2) \
+ $(use_enable gles2 cogl-gles2) \
+ $(use_enable gles2 xlib-egl-platform) \
+ $(usex gles2 --with-default-driver=$(usex opengl gl gles2)) \
+ $(use_enable gstreamer cogl-gst) \
+ $(use_enable introspection) \
+ $(use_enable kms kms-egl-platform) \
+ $(use_enable pango cogl-pango) \
+ --disable-unit-tests \
+ $(use_enable wayland wayland-egl-platform) \
+ $(use_enable wayland wayland-egl-server) \
+ --disable-profile
+# $(use_enable profile)
+}
+
+src_install() {
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/{*.c,*.jpg}
+ fi
+
+ gnome2_src_install
+
+ # Remove silly examples-data directory
+ rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
+}