summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-10-16 15:58:42 +0200
committerDavid Seifert <soap@gentoo.org>2021-10-16 15:58:42 +0200
commitfde2134e876bc931ece64f655410f2efbe42db42 (patch)
treeeecc37feba59421edf974225f089fd8e99888bba /media-libs
parentmedia-libs/cal3d: port to EAPI 8 (diff)
downloadgentoo-fde2134e876bc931ece64f655410f2efbe42db42.tar.gz
gentoo-fde2134e876bc931ece64f655410f2efbe42db42.tar.bz2
gentoo-fde2134e876bc931ece64f655410f2efbe42db42.zip
media-libs/flickcurl: port to EAPI 8
Closes: https://bugs.gentoo.org/729212 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/flickcurl/flickcurl-1.26.ebuild26
1 files changed, 11 insertions, 15 deletions
diff --git a/media-libs/flickcurl/flickcurl-1.26.ebuild b/media-libs/flickcurl/flickcurl-1.26.ebuild
index ae2503f8cd35..96f1e11eec80 100644
--- a/media-libs/flickcurl/flickcurl-1.26.ebuild
+++ b/media-libs/flickcurl/flickcurl-1.26.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=8
inherit autotools
@@ -12,33 +12,29 @@ SRC_URI="http://download.dajobe.org/flickcurl/${P}.tar.gz"
LICENSE="|| ( LGPL-2.1 GPL-2 Apache-2.0 )"
SLOT="0"
KEYWORDS="amd64 arm64 x86"
-IUSE="doc raptor static-libs"
+IUSE="raptor"
-RDEPEND=">=net-misc/curl-7.10.0
+RDEPEND="
+ >=net-misc/curl-7.10.0
>=dev-libs/libxml2-2.6.8:2
raptor? ( media-libs/raptor:2 )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gtk-doc-am
virtual/pkgconfig"
src_prepare() {
- if ! use doc ; then
- # Only install html documentation when the use flag is enabled
- sed -e '/gtk-doc.make/d' \
- -e 's:+=:=:' \
- -i docs/Makefile.am || die
- fi
-
+ default
eautoreconf
}
src_configure() {
econf \
- $(use_with raptor) \
- $(use_enable static-libs static)
+ --disable-gtk-doc \
+ $(use_with raptor)
}
src_install() {
- emake DESTDIR="${D}" TARGET_DIR=/usr/share/doc/${PF}/html install
- dodoc AUTHORS ChangeLog NEWS README
+ default
find "${ED}" -name '*.la' -delete || die
}