summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-04-25 07:54:05 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-04-25 07:56:00 +0000
commit0810609af1d6d3e0f2df719bb8f3d0b46d8367f1 (patch)
tree79662fc1cecc76f21c09f358ce1388e4519ff800 /media-plugins/alsa-plugins
parentx11-misc/qtfm: Old (diff)
downloadgentoo-0810609af1d6d3e0f2df719bb8f3d0b46d8367f1.tar.gz
gentoo-0810609af1d6d3e0f2df719bb8f3d0b46d8367f1.tar.bz2
gentoo-0810609af1d6d3e0f2df719bb8f3d0b46d8367f1.zip
media-plugins/alsa-plugins: respect EPREFIX, bug #673464
Sammy Pfeiffer discovered and provided a fix for alsa-plugins where from version 1.1.7 new option got a default without $(prefix): --with-alsalconfdir=/etc/alsa/conf.d The fix is to add a prefix: --with-alsalconfdir="${EPREFIX}"/etc/alsa/conf.d Reported-by: Sammy Pfeiffer Closes: https://bugs.gentoo.org/673464 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'media-plugins/alsa-plugins')
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.1.8-r1.ebuild101
1 files changed, 101 insertions, 0 deletions
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.1.8-r1.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.1.8-r1.ebuild
new file mode 100644
index 000000000000..ee154ee1e670
--- /dev/null
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.1.8-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic multilib multilib-minimal
+
+DESCRIPTION="ALSA extra plugins"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/plugins/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux"
+IUSE="arcam_av debug ffmpeg jack libav libsamplerate +mix oss pulseaudio speex +usb_stream"
+
+RDEPEND="
+ >=media-libs/alsa-lib-${PV}:=[${MULTILIB_USEDEP}]
+ ffmpeg? (
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:0= )
+ )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.8-r1:=[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ speex? (
+ >=media-libs/speex-1.2.0:=[${MULTILIB_USEDEP}]
+ media-libs/speexdsp[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
+ # failed assert. As the code works just fine with asserts disabled, for now
+ # disable them waiting for a better solution.
+ sed -i \
+ -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
+ pulse/Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ use debug || append-cppflags -DNDEBUG
+
+ local myeconfargs=(
+ # default does not contain $prefix: bug #673464
+ --with-alsalconfdir="${EPREFIX}"/etc/alsa/conf.d
+
+ --with-speex="$(usex speex lib no)"
+ $(use_enable arcam_av arcamav)
+ $(use_enable ffmpeg libav)
+ $(use_enable jack)
+ $(use_enable libsamplerate samplerate)
+ $(use_enable mix)
+ $(use_enable oss)
+ $(use_enable pulseaudio)
+ $(use_enable speex speexdsp)
+ $(use_enable usb_stream usbstream)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ cd doc || die
+ dodoc upmix.txt vdownmix.txt README-pcm-oss
+ use jack && dodoc README-jack
+ use libsamplerate && dodoc samplerate.txt
+ use ffmpeg && dodoc lavrate.txt a52.txt
+
+ if use pulseaudio; then
+ dodoc README-pulse
+ # install ALSA configuration files
+ # making PA to be used by alsa clients
+ insinto /usr/share/alsa
+ doins "${FILESDIR}"/pulse-default.conf
+ insinto /usr/share/alsa/alsa.conf.d
+ doins "${FILESDIR}"/51-pulseaudio-probe.conf
+ # bug #410261, comment 5+
+ # seems to work fine without any path
+ sed -i \
+ -e "s:/usr/lib/alsa-lib/::" \
+ "${ED%/}"/usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf || die #410261
+ fi
+
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+}
+
+pkg_postinst() {
+ if use pulseaudio; then
+ einfo "The PulseAudio device is now set as the default device if the"
+ einfo "PulseAudio server is found to be running. Any custom"
+ einfo "configuration in /etc/asound.conf or ~/.asoundrc for this"
+ einfo "purpose should now be unnecessary."
+ fi
+}