summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerenc Erki <erkiferenc@gmail.com>2018-11-30 21:35:12 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-08-03 09:09:35 +0300
commit98955a92619bb777caa863cb761322aaf217d9c2 (patch)
tree27f4c52204c1e8486b02deec700fa0396a5c596a /media-plugins/alsaequal/alsaequal-0.7.1.ebuild
parentprofiles/package.mask: mask dev-ruby/priorityqueue (diff)
downloadgentoo-98955a92619bb777caa863cb761322aaf217d9c2.tar.gz
gentoo-98955a92619bb777caa863cb761322aaf217d9c2.tar.bz2
gentoo-98955a92619bb777caa863cb761322aaf217d9c2.zip
media-plugins/alsaequal: re-add package
Courtesy of David Racine from the bassdr overlay (https://github.com/bassdr/gentoo-local-overlay). Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Ferenc Erki <erkiferenc@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10529 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-plugins/alsaequal/alsaequal-0.7.1.ebuild')
-rw-r--r--media-plugins/alsaequal/alsaequal-0.7.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-plugins/alsaequal/alsaequal-0.7.1.ebuild b/media-plugins/alsaequal/alsaequal-0.7.1.ebuild
new file mode 100644
index 000000000000..06802aa79d4a
--- /dev/null
+++ b/media-plugins/alsaequal/alsaequal-0.7.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-minimal toolchain-funcs
+
+DESCRIPTION="A real-time adjustable equalizer plugin for ALSA"
+HOMEPAGE="https://github.com/bassdr/alsaequal"
+SRC_URI="https://github.com/bassdr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-plugins/caps-plugins[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wall -fPIC -DPIC" \
+ LD="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS} -shared" \
+ Q= \
+ SND_PCM_LIBS="-lasound" \
+ SND_CTL_LIBS="-lasound"
+}
+
+multilib_src_install() {
+ insinto /usr/$(get_libdir)/alsa-lib
+ doins *.so
+}