summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 19:38:14 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-03 19:38:14 +0100
commit3d64b3e2bc3523e5681bef5855c72f329aeb7915 (patch)
treee7205822765fd8362fff98b023384fcffd4f21e2 /media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild
parentmedia-plugins/gmpc-playlistsort: Port to EAPI 6 (diff)
downloadgentoo-3d64b3e2bc3523e5681bef5855c72f329aeb7915.tar.gz
gentoo-3d64b3e2bc3523e5681bef5855c72f329aeb7915.tar.bz2
gentoo-3d64b3e2bc3523e5681bef5855c72f329aeb7915.zip
media-plugins/gmpc-shout: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild')
-rw-r--r--media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild b/media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild
index 1f1c70e1436e..d99728d90df6 100644
--- a/media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild
+++ b/media-plugins/gmpc-shout/gmpc-shout-0.20.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
+EAPI=6
DESCRIPTION="This plugin calls ogg123 and points it at mpd's shoutstream"
HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_SHOUT"
@@ -12,22 +12,23 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="nls"
-RDEPEND=">=media-sound/gmpc-${PV}
+RDEPEND="
+ >=media-sound/gmpc-${PV}
media-sound/vorbis-tools[ogg123]
- dev-libs/libxml2
- x11-libs/cairo"
+ dev-libs/libxml2:=
+ x11-libs/cairo:="
DEPEND="${RDEPEND}
virtual/pkgconfig
- nls? ( dev-util/intltool
- sys-devel/gettext )"
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
src_configure() {
- econf \
- --disable-dependency-tracking \
- $(use_enable nls)
+ econf $(use_enable nls)
}
src_install() {
- emake DESTDIR="${D}" install || die
- find "${ED}" -name "*.la" -delete || die
+ default
+ find "${D}" -name '*.la' -delete || die
}